Package Details: firefox-beta-bin-all-localizations 79.0b5-1

Git Clone URL: https://aur.archlinux.org/firefox-beta-bin-all-localizations.git (read-only, click to copy)
Package Base: firefox-beta-bin-all-localizations
Description: Perl script for installing latest FF beta in the language of your choice
Upstream URL: https://www.mozilla.com/firefox/channel/#beta
Licenses: GPL, MPL, LGPL
Conflicts: firefox-beta-bin
Provides: firefox=79.0b5
Submitter: None
Maintainer: symen
Last Packager: symen
Votes: 32
Popularity: 0.000000
First Submitted: 2011-07-10 22:14
Last Updated: 2020-07-08 11:01

Required by (124)

Sources (3)

Latest Comments

1 2 3 Next › Last »

symen commented on 2020-04-25 16:37

@TheGoliath How a meta package would help? Users don't need to install a group of packages together?

Do you mean a split package? This would help building a package for each language with the same PKGBUILD. However we would have to declare one source per language and users would have to download/verify every archive before building their package (unless I am missing something).

TheGoliath commented on 2020-04-25 16:21

a meta-package would be better

rains commented on 2018-01-24 06:46

diff --git a/PKGBUILD b/PKGBUILD
index [`30c7c0f`](https://aur.archlinux.org/cgit/aur.git/commit/?h=firefox-beta-bin-all-localizations&id=30c7c0f)..3a62072 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -38,7 +38,7 @@ package() {
ln -Ts /usr/share/hyphen "${pkgdir}/usr/lib/${_mypkgn}/hyphenation"

install -m644 firefox-beta-bin.desktop ${pkgdir}/usr/share/applications/
-  install -m644 ${srcdir}/firefox/browser/icons/mozicon128.png ${pkgdir}/usr/share/pixmaps/${_mypkgn}.png
+  install -m644 ${srcdir}/firefox/browser/chrome/icons/default/default128.png ${pkgdir}/usr/share/pixmaps/${_mypkgn}.png
}
md5sums=('4c0ca11a8034b53c0c5b7b9830442cd7'
        'b4d5afd97c8ac229f6027d7853c73c0c'

symen commented on 2017-10-13 20:57

@bjo
This should work now. I (wrongly) assumed the "dictionaries" folder to be there for every language.

bjo commented on 2017-10-13 19:43

Something is broken:

:: "firefox-57.0b8.tar.bz2" already present in the filesystem, skip download
:: "firefox-57.0b8-SHA512SUMS" already present in the filesystem, skip download
:: verifying sha512 checksum ...
DONE
==> Entering fakeroot environment...
==> Starting package()...
rm: cannot remove '/home/bjo/Sync/arch/firefox-beta-bin-all-localizations/pkg/firefox-beta-bin-all-localizations/usr/lib/firefox-beta/dictionaries': No such file or directory
==> ERROR: A failure occurred in package().
Aborting...

symen commented on 2017-09-29 14:07

@jgottlander
Good call, I set firefox-beta-bin as a conflicting package.

jgottlander commented on 2017-09-29 08:41

This package is in conflict with AUR/firefox-beta-bin, but never checks for it. Had to uninstall manually.

symen commented on 2017-03-24 20:15

@dcg
Actually the build script downloads checksums from Mozilla's archive at build time (this is the SHA512SUMS file you see in the logs), so either the hash was wrong or the firefox tar you downloaded was corrupt.

I tried building the package for es-ES and it worked, so if there was an issue on Mozilla's side it should be fixed by now.

dcg commented on 2017-03-24 18:47

** GET http://releases.mozilla.org/pub/firefox/releases/53.0b6/linux-x86_64/es-ES/firefox-53.0b6.tar.bz2 ==> 200 OK (156s)
** GET https://ftp.mozilla.org/pub/firefox/releases/53.0b6/SHA512SUMS ==> 200 OK (1s)
:: verifying sha512 checksum ... FAILED

Maybe forgot to update the sha512sum?

symen commented on 2016-06-20 17:48

Sorry for the delay, I updated the package on my machine but forgot to push after checking if it was working fine...