Package Details: firecracker-git 1:r2700.dc893ea2-1

Git Clone URL: https://aur.archlinux.org/firecracker-git.git (read-only, click to copy)
Package Base: firecracker-git
Description: Secure and fast microVMs for serverless computing
Upstream URL: https://github.com/firecracker-microvm/firecracker
Licenses: Apache:2.0
Submitter: gdamjan
Maintainer: gdamjan
Last Packager: gdamjan
Votes: 2
Popularity: 0.000001
First Submitted: 2019-02-06 23:04
Last Updated: 2021-03-29 16:16

Latest Comments

gdamjan commented on 2021-01-15 02:58

The docker thing…

unfortunately that's upstreams only documented way of building the project :(

if you find a better way, inform me. In the meanwhile I can propose: 1) use cloud-hypervisor https://aur.archlinux.org/packages/cloud-hypervisor 2) perhaps if podman can run on your CI, make a symlink to it to replace docker

rageltman commented on 2021-01-15 00:26

The docker thing is a non-starter for CI building in docker or via chroot:

[2021-01-14T21:15:19.832Z] ==> Starting build()...
[2021-01-14T21:15:19.832Z] [Firecracker devtool] Error accessing Docker. Please make sure the Docker daemon is running and that you are part of the docker group.
[2021-01-14T21:15:19.832Z]  Error: 1, command output: Cannot connect to the Docker daemon at unix:///var/run/docker.sock. Is the docker daemon running?
[2021-01-14T21:15:19.832Z]  For more information, see https://docs.docker.com/install/linux/linux-postinstall/
[2021-01-14T21:15:19.832Z] ==> ERROR: A failure occurred in build().
[2021-01-14T21:15:19.832Z]     Aborting...
script returned exit code 255

gdamjan commented on 2019-06-08 10:47

tools/devtool makes docker a requirement for the build. I'm not sure I'm comfortable with that.

OTOH, it's not much worse than rustup toolchain install 1.32.0 :/

joerichey commented on 2019-05-28 04:42

This build currently does not produce a working build of firecracker.

Per this Github Issue: https://github.com/firecracker-microvm/firecracker/issues/997, firecracker won't work if built with Rust 1.33 or later. There are two main ways to fix this,

1) Have the "rustup install" line expicitly getting rust 1.32 (instead of the latest stable)

i.e. run "rustup toolchain install 1.32.0"

2) Use the recomended steps from github (https://github.com/firecracker-microvm/firecracker/blob/master/docs/getting-started.md#building-firecracker),

i.e. run "tools/devtool -y build --release"