Package Details: firebird-superserver 2.5.9.27139-1

Git Clone URL: https://aur.archlinux.org/firebird-superserver.git (read-only, click to copy)
Package Base: firebird-superserver
Description: A open source SQL relational database management system (RDMS)
Upstream URL: http://www.firebirdsql.org/
Licenses: custom:IPL, custom:IDPL
Conflicts: firebird-classicserver, libfbclient
Provides: libfbclient=2.5.9.27139
Submitter: ik_5
Maintainer: crank
Last Packager: crank
Votes: 32
Popularity: 0.75
First Submitted: 2010-10-08 16:12
Last Updated: 2019-12-06 09:12

Dependencies (2)

Required by (40)

Sources (5)

Latest Comments

« First ‹ Previous 1 2 3 4 5 Next › Last »

crank commented on 2018-03-21 13:12

@d.fenzl, should be working now.

@fuan_k, as this package provides libfbclient libs. Not neccessary to keep libfbclient from extra repo installed. No problem here with starting the systemd service.

fuan_k commented on 2018-03-15 09:13

Thanks for maintaining this package!

I'm having some trouble getting the systemd service to run properly,

Supervising process 28080 which is not our child. We'll most likely not notice when it exits. Killing process 28080 (n/a) with signal SIGKILL.

Had to resort to manually start the server with sudo su -c "/usr/lib/firebird/bin/fbguard -daemon"

Also, a bit annoyed that it conflicts with package libfbclient, as I was using it with an embedded client.

d.fenzl commented on 2018-03-14 12:57

No problem, for now its just the dev system.

Thank You for your work.

crank commented on 2018-03-14 12:45

I am looking into this, sorry for the inconvenience!

d.fenzl commented on 2018-03-14 09:42

Since the update to version 2.5.8 i am not able to connect to any of my existing databases due to ancharacter set error. If i use the same database on an other system, windows or ubuntu based, using firebird 2.5.8 is no problem, so i asume it must be a problem with arch/aur. The error is the following:

IBPP::SQLException Context: Database::Connect Message: isc_attach_database failed

SQL Message : -924 Connection error

Engine Code : 335544325 Engine Message : bad parameters on attach or create database CHARACTER SET ISO8859_1 is not defined

jkepler commented on 2017-05-08 04:51

Due to some reason i downloaded the wrong tar ball.
The current snapshot works perfectly.
Thank You!

crank commented on 2017-05-05 11:03

@jkepler Have you updated your local package sources? There are some old CXXFLAGS in the command line in your log. I removed "-std=gnu++98" from CXXFLAGS in the latest version.

jkepler commented on 2017-05-05 09:40

during compilation (makepkg) i get this errors
[..]
g++ -D_FORTIFY_SOURCE=2 -DBOOT_BUILD -I../src/include/gen -I../src/include -I../src/vulcan -DNAMESPACE=Vulcan -DNDEBUG -ggdb -DFB_SEND_FLAGS=MSG_NOSIGNAL -DLINUX -DAMD64 -pipe -MMD -fPIC -fmessage-length=0 -O3 -fno-omit-frame-pointer -pthread -march=x86-64 -mtune=generic -O2 -pipe -fstack-protector-strong -std=gnu++98 -flifetime-dse=1 -fno-rtti -fno-rtti -fno-rtti -c ../src/jrd/unicode_util.cpp -o ../temp/boot/jrd/unicode_util.o
In file included from /usr/include/unicode/utypes.h:38:0,
from /usr/include/unicode/ustring.h:21,
from ../src/jrd/unicode_util.cpp:40:
/usr/include/unicode/umachine.h:347:13: Fehler: »char16_t« bezeichnet keinen Typ
typedef char16_t UChar;
^~~~~~~~
In file included from /usr/include/unicode/utypes.h:39:0,
from /usr/include/unicode/ustring.h:21,
from ../src/jrd/unicode_util.cpp:40:
/usr/include/unicode/uversion.h:167:55: Fehler: »UChar« bezeichnet keinen Typ
u_versionFromUString(UVersionInfo versionArray, const UChar *versionString);
^~~~~
[..]

crank commented on 2017-03-30 13:41

@stas-t

You are right! Fixed the permissions but using fbmsg=/usr/lib/firebird seems like the proper solution. Saw that edit too late :)

stas-t commented on 2017-03-29 14:59

There is one another thing: to make isql happy we probably need to make /var/lib/firebird/system/*.msg readable for normal users:

# chmod 444 /var/lib/firebird/system/*.msg
# chmod 755 /var/lib/firebird/system

Otherwise isql-fb will complain:

can't format message 17:141 -- message file /var/lib/firebird/system/firebird.msg not found

EDIT:

Or maybe using --with-fbmsg=/usr/lib/firebird/ is even better since those files are not variable?