Package Details: ffsend 0.2.55-1

Git Clone URL: https://aur.archlinux.org/ffsend.git (read-only)
Package Base: ffsend
Description: Easily and securely share files from the command line. A Firefox Send client.
Upstream URL: https://gitlab.com/timvisee/ffsend
Keywords: firefox send
Licenses: GPL3
Provides: ffsend
Submitter: timvisee
Maintainer: timvisee
Last Packager: timvisee
Votes: 7
Popularity: 0.98
First Submitted: 2019-03-27 17:09
Last Updated: 2019-10-30 22:05

Latest Comments

Flubbadub commented on 2019-04-09 09:58

Yeah, no problem, I suspected it's something like that. As I say it's not too important because I am using the -bin package for now. Thanks for your efforts anyway!

timvisee commented on 2019-04-05 13:01

@Flubbadub Good question. The problem with rustup is that you can't properly specify what Rust version must be used (like what is possible when using rust>=1.32). Because of this, the rust>=1.32 dependency is set, which is not compatible with the rustup package.

I did try to detect the installed Rust version when used through rustup when installing the package, to warn the user if they're using an outdated Rust version. But that didn't work so well. I might give it another try soon. If that works, the rust dependency can be removed, allowing you to use either rust or rustup as cargo provider which solves your issue (if that makes sense).

Flubbadub commented on 2019-04-05 09:34

Is it possible to make this work with rustup? Currently it tries to make me install rust in order to build it even though rustup provides rust. I think this is due to the version of rust being specified - it works if I just remove the version constraint. I did wonder if this was an issue with the AUR helper program I use but I also tried building with makepkg directly and that has the same issue.

For now I am just using ffsend-bin so no worries if this is difficult/not possible. I had a quick look and couldn't find a decent way.