Package Details: ffmpeg0.10 0.10.16-3

Git Clone URL: https://aur.archlinux.org/ffmpeg0.10.git (read-only)
Package Base: ffmpeg0.10
Description: Complete solution to record, convert and stream audio and video
Upstream URL: http://ffmpeg.org/
Licenses: GPL
Provides: ffmpeg-compat, libavcodec.so, libavdevice.so, libavfilter.so, libavformat.so, libavutil.so, libpostproc.so, libswresample.so, libswscale.so
Replaces: ffmpeg-compat
Submitter: Barthalion
Maintainer: paul.wilk
Last Packager: paul.wilk
Votes: 36
Popularity: 0.000092
First Submitted: 2017-01-20 20:26
Last Updated: 2018-02-20 21:36

Required by (79)

Sources (2)

Latest Comments

1 2 3 Next › Last »

mokkurkalve commented on 2019-07-21 09:49

Mm. It compiles in clean chroot with --disable-libx264

mokkurkalve commented on 2019-07-19 12:57

Build in clean chroot fails thus:

(...snip...) In file included from libavcodec/libx264.c:24: libavcodec/avcodec.h:2775:30: note: declared here 2775 | attribute_deprecated int partitions; | ^~~~~~~~~~ libavcodec/libx264.c:541:5: warning: ‘crf’ is deprecated [-Wdeprecated-declarations] 541 | avctx->crf = x4->params.rc.f_rf_constant; | ^~~~~ In file included from libavcodec/libx264.c:24: libavcodec/avcodec.h:2698:32: note: declared here 2698 | attribute_deprecated float crf; | ^~~ libavcodec/libx264.c: In function ‘X264_init_static’: libavcodec/libx264.c:595:9: error: ‘x264_bit_depth’ undeclared (first use in this function) 595 | if (x264_bit_depth == 8) | ^~~~~~~~~~~~~~ make: [common.mak:45: libavcodec/libx264.o] Error 1 make: Waiting for unfinished jobs.... ==> ERROR: A failure occurred in build(). Aborting... ==> ERROR: Build failed, check /home/eivind/work/build/chroot/eivind/build

framas commented on 2018-09-25 07:12

@Fux I removed "--enable-libx264 \" in PkGBUILD and it did compile for me. I need it for barcoo-clickshare and this works without x264....

naraesk commented on 2018-09-08 17:39

Have the same problem as Fuxy

Fuxy commented on 2018-08-20 02:26

This seems to fail to build for me with : "make: *** [common.mak:45: libavcodec/libx264.o] Error 1"

Dies this happen to anyone else or did i miss something?

jshap commented on 2018-02-08 06:55

kind of frustrating that this keeps happening, but I guess it's a symptom of us being forced (probably by spotify) to use this outdated package. unfortunately I'm afraid that one of these days there's going to be an update that is actually incompatible.

ector commented on 2018-02-06 15:44

ok, I did so I gave: sudo pacman -Rdd libvpx It is given sudo pacman -Syu

Niklas commented on 2018-02-06 14:39

Recompiling is all you need to do. Bump the pkgrel flag and rebuild or reinstall from AUR and it will work again

ector commented on 2018-02-06 10:16

i have this error: error: failed to prepare transaction (could not satisfy dependencies) :: ffmpeg0.10: installing libvpx (1.7.0-1) breaks dependency 'libvpx.so=4-64'

axfelix commented on 2018-02-06 05:05

Hitting one of these again...

error: failed to prepare transaction (could not satisfy dependencies) :: ffmpeg0.10: installing libvpx (1.7.0-1) breaks dependency 'libvpx.so=4-64'