Package Details: ffmpeg-ndi 4.4.1-1

Git Clone URL: https://aur.archlinux.org/ffmpeg-ndi.git (read-only, click to copy)
Package Base: ffmpeg-ndi
Description: Complete solution to record, convert and stream audio and video with NDI restored and enabled
Upstream URL: https://ffmpeg.org/
Keywords: audio codec convert encoder ffmpeg media ndi newtek vaapi video
Licenses: custom: nonfree and unredistributable
Conflicts: ffmpeg
Provides: ffmpeg, libavcodec.so, libavdevice.so, libavfilter.so, libavformat.so, libavutil.so, libpostproc.so, libswresample.so, libswscale.so
Submitter: tytan652
Maintainer: tytan652
Last Packager: tytan652
Votes: 1
Popularity: 0.143405
First Submitted: 2020-01-17 10:13
Last Updated: 2021-11-06 12:29

Dependencies (67)

Required by (1000)

Sources (7)

Pinned Comments

tytan652 commented on 2021-03-23 18:34

Don't put this package out of date because it blocks update, just reinstall ffmpeg, update and reinstall ffmpeg-ndi

Sometimes ffmpeg needs to be recompiled against newer library

Latest Comments

tytan652 commented on 2022-01-19 10:43

FFmpeg 5 is not even on the Arch repo, so putting this package as out of date was a wrong move in my opinion.

My FFmpeg packages try to be drop in replacement, so I only update when Arch do it.

I'm the maintainer of the patch and when I create it and decided that if NDI no longer works with what the patch do, I will not work on making it compatible.

Why ? I only use code that were in FFmpeg source code. I just revert a commit nothing else.

tytan652 commented on 2022-01-19 06:20

The NDI patch used is not meant to be used against ffmpeg-master but only FFmpeg 4.2 to 4.4.1. And it was not even meant to be usable with NDI 5.

firoz commented on 2022-01-18 23:48

Doesn't build with ffmpeg-master:

patching file libavfilter/vf_libvmaf.c
Hunk #1 succeeded at 72 with fuzz 2.
patching file configure
Hunk #2 succeeded at 1784 with fuzz 2 (offset 49 lines).
Hunk #3 succeeded at 3506 (offset 93 lines).
Hunk #4 FAILED at 6340.
1 out of 4 hunks FAILED -- saving rejects to file configure.rej
patching file doc/indevs.texi
Hunk #1 succeeded at 1136 (offset 20 lines).
patching file doc/outdevs.texi
Hunk #1 succeeded at 296 (offset 30 lines).
patching file libavdevice/Makefile
Hunk #1 succeeded at 20 (offset -1 lines).
Hunk #2 succeeded at 64 (offset 2 lines).
patching file libavdevice/alldevices.c
Hunk #1 FAILED at 33.
1 out of 1 hunk FAILED -- saving rejects to file libavdevice/alldevices.c.rej

tytan652 commented on 2021-03-23 18:34

Don't put this package out of date because it blocks update, just reinstall ffmpeg, update and reinstall ffmpeg-ndi

Sometimes ffmpeg needs to be recompiled against newer library