Package Details: ffmpeg-full 4.4-1

Git Clone URL: https://aur.archlinux.org/ffmpeg-full.git (read-only, click to copy)
Package Base: ffmpeg-full
Description: Complete solution to record, convert and stream audio and video (all possible features including libfdk-aac)
Upstream URL: https://www.ffmpeg.org/
Keywords: audio codec convert cuda cuvid decklink encoder fdk-aac fdkaac hwaccel libnpp media nvenc svt video
Licenses: custom: nonfree and unredistributable
Conflicts: ffmpeg
Provides: ffmpeg, libavcodec.so, libavdevice.so, libavfilter.so, libavformat.so, libavresample.so, libavutil.so, libpostproc.so, libswresample.so, libswscale.so
Submitter: rpolzer
Maintainer: dbermond
Last Packager: dbermond
Votes: 105
Popularity: 0.020110
First Submitted: 2013-01-24 11:17
Last Updated: 2021-04-09 22:04

Dependencies (113)

Required by (1000)

Sources (8)

Latest Comments

« First ‹ Previous ... 4 5 6 7 8 9 10 11 12 13 14 ... Next › Last »

dbermond commented on 2019-06-03 01:44

@Verequies You're not supposed to get an error about an outdated libvmaf. Please make sure that you have the latest vmaf installed, which currently is 1.3.14. If you're using vmaf-git, make sure that you have the latest git version installed. Also make sure that you're using the latest version of this aur package for building.

I cannot help you to solve the Jellyfin problem.

Verequies commented on 2019-06-03 01:24

How does one solve the error 'ERROR: libvmaf >= 1.3.9 not found using pkg-config'?

Also I have an issue with Jellyfin, I require the latest ffmpeg installed, but Jellyfin only works with ffmpeg 4.0, how can I build a static executable of the previous 4.0 ffmpeg-full?

dbermond commented on 2019-05-12 15:14

@kaykay91 Probably you need to rebuild kvazaar against crypto++ 8.

kaykay91 commented on 2019-05-03 12:00

Despite having the kvazaar package installed it still errors out: -> Running ffmpeg configure script... ERROR: kvazaar >= 0.8.1 not found using pkg-config

dbermond commented on 2019-04-03 00:41

@clpwn There are some ways to do this. For example, temporarily uninstall x264 with 'pacman -Rdd' to ignore the dependencies check. Then install it back again with 'pacman -Syu --asdeps x264' and then rebuild ffmpeg-full against the new x264.

clpwn commented on 2019-04-01 02:50

There's a dependency conflict with the new x264 version released.

error: failed to prepare transaction (could not satisfy dependencies)
:: installing x264 (2:157.r72db4377-1) breaks dependency 'libx264.so=155-64' required by ffmpeg-full

dbermond commented on 2019-03-13 20:55

@BrLi This is not possible with ffmpeg because when you enable a component at build time it will be always needed when running the final binary, otherwise you will get a 'cannot load shared library' error.

BrLi commented on 2019-03-11 14:26

Can any part of the dependencies be optional? I mean, I'd like to have a full ffmpeg but works like the official package with additional functions when I install corresponding libs/packages.

Martchus commented on 2019-03-06 09:50

Why would that be the right thing to do?

Like I said, some people are actually using the testing repos.

But not bumping the pkgrel at all is an option, too. When this is the case I usually increase the pkgrel myself to e.g. 1.1 so I would still get an update if the pkgrel changes because a patch has been added or something else in the package has been changed.

If I'm fast enough I sometimes even build against staging and move the package later from my own staging to my own testing or regular repository. For this increasing the pkgrel in the AUR is not really helpful anyways. So that kind of sophisticated way to build packages also speaks for just letting the users manage this on their own.

spider-mario commented on 2019-03-06 07:45

Why would that be the right thing to do? And for an AUR package, wouldn’t it make more sense to just let users rebuild the package when needed?