Package Details: ffmpeg-full 4.4-1

Git Clone URL: https://aur.archlinux.org/ffmpeg-full.git (read-only, click to copy)
Package Base: ffmpeg-full
Description: Complete solution to record, convert and stream audio and video (all possible features including libfdk-aac)
Upstream URL: https://www.ffmpeg.org/
Keywords: audio codec convert cuda cuvid decklink encoder fdk-aac fdkaac hwaccel libnpp media nvenc svt video
Licenses: custom: nonfree and unredistributable
Conflicts: ffmpeg
Provides: ffmpeg, libavcodec.so, libavdevice.so, libavfilter.so, libavformat.so, libavresample.so, libavutil.so, libpostproc.so, libswresample.so, libswscale.so
Submitter: rpolzer
Maintainer: dbermond
Last Packager: dbermond
Votes: 105
Popularity: 0.021768
First Submitted: 2013-01-24 11:17
Last Updated: 2021-04-09 22:04

Dependencies (113)

Required by (1000)

Sources (8)

thefirstofthe300 commented on 2014-07-22 23:28

Please add libcl to the list of dependencies. The current PKGBUILD fails without it.

isiachi commented on 2014-07-22 15:49

Bump to version 2.2.5.
Added these flags:
--enable-frei0r --enable-libopencv --enable-libvidstab --enable-libutvideo --enable-opencl.

new update soon.

rpolzer commented on 2014-07-11 19:36

Can anyone else take over this package?

What needs to be done:

- Sync with extra/fffmpeg-2.2.4-3 (just take over the diffs from the official package since 2.2.2-3).
- Look over the disabled stuff at the bottom (commented out flags). Some of these can be moved to the enabled flags more upwards, e.g. - as mentioned in the comments - libvidstab.
- Start building the package until it fully downloaded. Then cancel that with ^C, and run the part from the PKGBUILD with "sh" in it from the comments at the bottom (the comment sign only needs to be removed from the "sh" line).
- This will output the new list of --flags. Replace the old list by the newly generated one.
- Enjoy!

I can do this for this package next week, but I'd prefer if someone could take it over in the future.

evorster commented on 2014-06-30 02:11

Hi there.
I added a package "vid.stab" to the aur. With this library installed the
--enable-libvidstab ./configure switch now works.

This enables a much improved video stabilization in ffmpeg, and, by extention mlt-git and transcode, which helps shotcut-git.

mitch_feaster commented on 2014-06-21 00:37

Broke again with the latest update to libx264/x264 until I re-installed. Can you please add that to makedepends?

mitch_feaster commented on 2014-05-21 05:24

After a recent update to x265 I was getting:

ffmpeg: error while loading shared libraries: libx265.so.13: cannot open shared object file: No such file or directory

Re-installing ffmpeg-full got rid of this error. Maybe you need to add x265 to makedepends as well?

justin8 commented on 2014-05-15 01:04

I'm not using either. I have libsodium and zeromq both from community, but get that error with ffmpeg-full. See here: http://hastebin.com/ekisugalit.coffee

I last did a full update of packages yesterday.

MagicAndWires commented on 2014-05-14 22:47

@justin8

It's only required if you've got libsodium-git installed. If you'd rather not have too many git dependencies, get rid of libsodium-git for libsodium from community, or rebuild zeromq against libsodium-git by grabbing the PKGBUILD from the ABS.

MagicAndWires commented on 2014-05-14 22:44

@justin8

It's only required if you've got libsodium-git installed. If you'd rather not have too many git dependencies, get rid of libsodium-git for libsodium from community, or rebuild zeromq against the libsodium-git by grabbing the PKGBUILD from the ABS.

MagicAndWires commented on 2014-05-14 22:44

@juston8

It's only required if you've got libsodium-git installed. If you'd rather not have too many git dependencies, get rid of libsodium-git for libsodium from community, or rebuild zeromq against the libsodium-git by grabbing the PKGBUILD from the ABS.