Package Details: ffmpeg-full 4.4-1

Git Clone URL: https://aur.archlinux.org/ffmpeg-full.git (read-only, click to copy)
Package Base: ffmpeg-full
Description: Complete solution to record, convert and stream audio and video (all possible features including libfdk-aac)
Upstream URL: https://www.ffmpeg.org/
Keywords: audio codec convert cuda cuvid decklink encoder fdk-aac fdkaac hwaccel libnpp media nvenc svt video
Licenses: custom: nonfree and unredistributable
Conflicts: ffmpeg
Provides: ffmpeg, libavcodec.so, libavdevice.so, libavfilter.so, libavformat.so, libavresample.so, libavutil.so, libpostproc.so, libswresample.so, libswscale.so
Submitter: rpolzer
Maintainer: dbermond
Last Packager: dbermond
Votes: 107
Popularity: 0.64
First Submitted: 2013-01-24 11:17
Last Updated: 2021-04-09 22:04

Dependencies (113)

Required by (1000)

Sources (8)

Latest Comments

« First ‹ Previous ... 9 10 11 12 13 14 15 16 17 18 19 ... Next › Last »

adsun commented on 2018-03-14 14:11

Ok. Thanks for the information.

dbermond commented on 2018-03-14 12:45

@adsun opencv 3.4.1-2 does not fix the ffmpeg build problem.

adsun commented on 2018-03-13 17:35

The opencv package was just rebuilt and updated to 3.4.1-2 from 3.4.1-1. opencv_version now executes successfully, so we should be able to re-enable libopencv.

dbermond commented on 2018-03-13 02:56

@wootywoot @piratejon @fitu996

This is a known upstream issue. I have temporarily disabled libopencv while there is not a fix for this.

Package is now building fine. Thank you for the interest.

fitu996 commented on 2018-03-13 01:19

@wootywoot @piratejon I meet the same problem.

But I believe this issue may be the broken of opencv. The last time I upgrade system, OpenCV is broken. Some of the package requires opencv broken, too. When calling "opencv_version" in shell, its says:

opencv_version: symbol lookup error: /usr/lib/libopencv_core.so.3.4: undefined symbol: _ZN3tbb10interface78internal15task_arena_base24internal_max_concurrencyEPKNS0_10task_arenaE

But another PC of mine doesn't meet the problem. OpenCV works well in that PC. Very strange.

piratejon commented on 2018-03-12 17:51

wootywoot i think i am seeing the same issue. one possibility is this: https://github.com/opencv/opencv/issues/10246#issuecomment-350116500 . from ffmpeg-build/config.log it does appear to be compiling as C rather than C++:

https://pastebin.com/tiPWqUF1

I am not sure what the next steps would be to change that.

wootywoot commented on 2018-03-12 16:55

I'm getting an error when trying to build this package that it cant find libopencv during the ffmpeg configuration script step but I do have opencv installed (and updated). Any ideas how to fix this?

dark-saber commented on 2018-03-05 08:47

friday13:

Some keys in AUR are not in the official repository keyrings, you have to add them to your keyring manually if you trust them. You can use something like gpg --recv-keys B4322F04D67658D8. See also Arch Wiki.

friday13 commented on 2018-03-04 09:46

ffmpeg-3.4.2.tar.xz ... FAILED (unknown public key B4322F04D67658D8)

desbma commented on 2018-02-16 19:41

@fsck_bieber The purpose of this package is to enable all features of FFmpeg. Even in a stock FFmpeg install there are several codecs with multiple encoders (ie. FFmpeg's vorbis and libvorbis)