Package Details: ffmpeg-full 4.1.4-1

Git Clone URL: https://aur.archlinux.org/ffmpeg-full.git (read-only)
Package Base: ffmpeg-full
Description: Complete solution to record, convert and stream audio and video (all possible features including nvenc, qsv and libfdk-aac)
Upstream URL: https://www.ffmpeg.org/
Keywords: audio codec convert cuda cuvid decklink encoder fdk-aac fdkaac ffmpeg hwaccel intel-svt libnpp media nvenc qsv quicksync svt vaapi video
Licenses: custom: nonfree and unredistributable
Conflicts: ffmpeg
Provides: ffmpeg, libavcodec.so, libavdevice.so, libavfilter.so, libavformat.so, libavresample.so, libavutil.so, libpostproc.so, libswresample.so, libswscale.so
Submitter: rpolzer
Maintainer: dbermond
Last Packager: dbermond
Votes: 78
Popularity: 1.272573
First Submitted: 2013-01-24 11:17
Last Updated: 2019-07-15 01:58

Dependencies (102)

Required by (903)

Sources (8)

Latest Comments

1 2 3 4 5 6 ... Next › Last »

dbermond commented on 2019-06-18 15:23

@nicoulaj This is a issue with the cuda package. May be fixed soon.

https://bugs.archlinux.org/task/62931?project=5&string=cuda

nicoulaj commented on 2019-06-18 12:39

Looks like build is broken because latest CUDA 10.1.168 blacklists gcc>8 ?

In file included from /opt/cuda/bin/../targets/x86_64-linux/include/cuda_runtime.h:83,
                 from <command-line>:
/opt/cuda/bin/../targets/x86_64-linux/include/crt/host_config.h:129:2: error: #error -- unsupported GNU version! gcc versions later than 8 are not supported!
  129 | #error -- unsupported GNU version! gcc versions later than 8 are not supported!
      |  ^~~~~
CC      libavfilter/vf_scale_npp.o
CC      libavfilter/vf_scale_qsv.o
make: *** [ffbuild/common.mak:95: libavfilter/vf_scale_cuda.ptx] Error 1

dbermond commented on 2019-06-12 01:54

@reddraggone9 This is true for installing cuda package directly with pacman. But when installing cuda as a missing dependency for this package with makepkg, '/etc/profile.d/cuda.sh' will be automatically sourced as I explained in the previous comment, and there is no need for any fix.

The only way I can see where this error can occur is if the user do something like running 'pacman -Syu cuda' and only after this execute 'makepkg'. But in this case, the user will be already informed by the cuda install script that he needs to relogin in order for nvcc to appear in the PATH. In this case, it will be not an issue, but an user fault.

dbermond commented on 2019-06-12 01:53

@G216 This error should not happen. makepkg automatically sources '/etc/profile' after installing the missing dependencies (cuda in this case), as you can see here:

https://git.archlinux.org/pacman.git/tree/scripts/makepkg.sh.in?h=v5.1.3#n280

'/etc/profile', by its turn, sources all scripts that are in '/etc/profile.d/':

https://git.archlinux.org/svntogit/packages.git/tree/trunk/profile?h=packages/filesystem&id=789ae7d4319a08908fa521bfeef47f663ec101d2#n26

This means that nvcc will be in PATH when installing cuda through makepkg, because the file '/etc/profile.d/cuda.sh' will be automatically sourced before building. This file sets the PATH variable to include the nvcc binary directory. The package builds fine in a chroot with devtools, and nvcc is found in PATH for the building process.

Are you using an AUR helper?

reddraggone9 commented on 2019-06-08 21:16

@G216 The nvcc command comes from the cuda dependency. Since that package (for whatever reason) installs to /opt, its binaries won't be in your existing PATH. As it mentions, logging out and back in (or rebooting for that matter) will add the new bin to your PATH variable.

Alternatively, you can source /etc/profile.d/cuda.sh and rerun the build for ffmpeg-full in the same terminal. I'm not sure what the proper fix for this would look like though...

G216 commented on 2019-06-04 14:35

/bin/sh: nvcc: command not found make: *** [ffbuild/common.mak:95: libavfilter/vf_scale_cuda.ptx] Error 127 ==> ERROR: A failure occurred in build(). Aborting... Error making: ffmpeg-full

dbermond commented on 2019-06-03 20:05

@Verequies I don't know what can be causing this for you. Package is building fine here.

Verequies commented on 2019-06-03 01:57

@dbermond All good about the Jellyfin problem, thought it was worth asking.

Everything is up to date, vmaf is 1.3.14 etc. The entire package builds if I comment out vmaf support, otherwise it shows that error.

dbermond commented on 2019-06-03 01:44

@Verequies You're not supposed to get an error about an outdated libvmaf. Please make sure that you have the latest vmaf installed, which currently is 1.3.14. If you're using vmaf-git, make sure that you have the latest git version installed. Also make sure that you're using the latest version of this aur package for building.

I cannot help you to solve the Jellyfin problem.

Verequies commented on 2019-06-03 01:24

How does one solve the error 'ERROR: libvmaf >= 1.3.9 not found using pkg-config'?

Also I have an issue with Jellyfin, I require the latest ffmpeg installed, but Jellyfin only works with ffmpeg 4.0, how can I build a static executable of the previous 4.0 ffmpeg-full?