Package Details: ffmpeg-full 4.1.3-2

Git Clone URL: (read-only)
Package Base: ffmpeg-full
Description: Complete solution to record, convert and stream audio and video (all possible features including nvenc, qsv and libfdk-aac)
Upstream URL:
Keywords: audio codec convert cuda cuvid decklink encoder fdk-aac fdkaac ffmpeg hwaccel libnpp media nvenc qsv quicksync vaapi video
Licenses: custom: nonfree and unredistributable
Conflicts: ffmpeg
Provides: ffmpeg,,,,,,,,,
Submitter: rpolzer
Maintainer: dbermond
Last Packager: dbermond
Votes: 76
Popularity: 0.260278
First Submitted: 2013-01-24 11:17
Last Updated: 2019-04-24 16:34

Dependencies (99)

Required by (870)

Sources (3)

Latest Comments

1 2 3 4 5 6 ... Next › Last »

dbermond commented on 2019-05-12 15:14

@kaykay91 Probably you need to rebuild kvazaar against crypto++ 8.

kaykay91 commented on 2019-05-03 12:00

Despite having the kvazaar package installed it still errors out: -> Running ffmpeg configure script... ERROR: kvazaar >= 0.8.1 not found using pkg-config

dbermond commented on 2019-04-03 00:41

@clpwn There are some ways to do this. For example, temporarily uninstall x264 with 'pacman -Rdd' to ignore the dependencies check. Then install it back again with 'pacman -Syu --asdeps x264' and then rebuild ffmpeg-full against the new x264.

clpwn commented on 2019-04-01 02:50

There's a dependency conflict with the new x264 version released.

error: failed to prepare transaction (could not satisfy dependencies)
:: installing x264 (2:157.r72db4377-1) breaks dependency '' required by ffmpeg-full

dbermond commented on 2019-03-13 20:55

@BrLi This is not possible with ffmpeg because when you enable a component at build time it will be always needed when running the final binary, otherwise you will get a 'cannot load shared library' error.

BrLi commented on 2019-03-11 14:26

Can any part of the dependencies be optional? I mean, I'd like to have a full ffmpeg but works like the official package with additional functions when I install corresponding libs/packages.

petko10 commented on 2019-02-25 15:19

I added the lines ''export LD_LIBRARY_PATH=/opt/cuda/lib64 export PATH=$PATH:/opt/cuda/bin'' to the PKGBUILD install section and that also works

Stefanitsky commented on 2019-02-09 08:21

Alltime headache = building this package

What problems did i had:

1) AUR packages missing
Solution: manual installation of each package

2) "One or more PGP signatures could not be verified! (unknown public key B4322F04D67658D8)"
Solution: $ gpg --recv-keys B4322F04D67658D8

3) nvcc: command not found
Solution: add /opt/cuda to your PATH variable in your .bashrc or whatever your shell is.
export LD_LIBRARY_PATH=/opt/cuda/lib64
export PATH=$PATH:/opt/cuda/bin

And also restart (reopen) your terminal to apply changes.

I hope this will help someone!

MichaelChou commented on 2018-11-12 04:15

@marmotteNZ Which shell do you use? /etc/profile.d/ append cuda bin directory to your PATH and some shells like fish might not have sourced scripts in /etc/profile.d/

dbermond commented on 2018-10-05 02:11

Important note:

  • in short: the next time you update your system, use this command: # pacman -Syu intel-media-driver. If you're using intel-media-driver-git you're not affected and you can skip this note.

  • the long story: intel-media-driver is now in the [community] official repository (it is a dependency of intel-media-sdk, which in turn is a dependency of this package). intel-media-driver from the official repository changed the pkgver major number, causing it to be seen as a downgrade by pacman (and AUR helpers of course). This means that pacman will not automatically pull/install intel-media-driver from official repositories when you simply use the usual -Syu. You need to manually specify intel-media-driver alongside with the -Syu command as shown above.