Package Details: ffmpeg-compat-54 1.2.12-3

Git Clone URL: https://aur.archlinux.org/ffmpeg-compat-54.git (read-only)
Package Base: ffmpeg-compat-54
Description: Compatibility package for ffmpeg to provide versions 54 of libavcodec, libavdevice and libavformat, not anymore provided by the ffmpeg package
Upstream URL: http://ffmpeg.org/
Licenses: GPL
Provides: libavcodec.so, libavdevice.so, libavformat.so
Submitter: Muflone
Maintainer: Muflone
Last Packager: Muflone
Votes: 87
Popularity: 0.288629
First Submitted: 2014-10-04 21:43
Last Updated: 2018-08-25 22:32

Required by (40)

Sources (7)

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 Next › Last »

positron commented on 2016-03-06 11:15

I get the following error:

ERROR: freetype2 not found

but I have freetype2-ubuntu installed!

das-ich commented on 2015-11-26 19:18

thanks, guys
now it builds normally

Muflone commented on 2015-11-22 12:41

@tuxfusion
you were correct, the patch was needed to fix the @das-ich issue.
Package updated

tuxfusion commented on 2015-11-20 22:03

Just a guess, this was reported and fixed upstream here: https://trac.ffmpeg.org/ticket/4956. We need to pull that commit into ffmpeg-compat-54 maybe ?

das-ich commented on 2015-11-18 17:18

error

libavcodec/libvpxenc.c:90:6: error: 'VP8E_UPD_ENTROPY' undeclared here (not in a function)
[VP8E_UPD_ENTROPY] = "VP8E_UPD_ENTROPY",
^
libavcodec/libvpxenc.c:90:6: error: array index in initializer not of integer type
libavcodec/libvpxenc.c:90:6: note: (near initialization for 'ctlidstr')
libavcodec/libvpxenc.c:91:6: error: 'VP8E_UPD_REFERENCE' undeclared here (not in a function)
[VP8E_UPD_REFERENCE] = "VP8E_UPD_REFERENCE",
^
libavcodec/libvpxenc.c:91:6: error: array index in initializer not of integer type
libavcodec/libvpxenc.c:91:6: note: (near initialization for 'ctlidstr')
libavcodec/libvpxenc.c:92:6: error: 'VP8E_USE_REFERENCE' undeclared here (not in a function)
[VP8E_USE_REFERENCE] = "VP8E_USE_REFERENCE",
^
libavcodec/libvpxenc.c:92:6: error: array index in initializer not of integer type
libavcodec/libvpxenc.c:92:6: note: (near initialization for 'ctlidstr')
common.mak:48: recipe for target 'libavcodec/libvpxenc.o' failed
make: *** [libavcodec/libvpxenc.o] Error 1

jonnybarnes commented on 2015-11-15 17:23

I can’t compile this. I get the following error:

```
Creating config.mak and config.h...
...
CC libavcodec/libvpxenc.o
common.mak:48: recipe for target 'libavcodec/libvpxenc.o' failed
```

Muflone commented on 2015-11-13 00:26

@ikonen
what version of freetype2 are you using?
the standard freetype2 package already has /usr/include/freetype2/freetype/freetype.h

Anonymous comment on 2015-11-09 16:05

For me it wasn't still working.
I had first to create the directory (/freetype) in /usr/include/freetype2/freetype and copy the file freetype.h to there.

After that the update was flawless.

Thanks guys.

Muflone commented on 2015-11-08 15:59

Package fixed for freetype.h issues

tasos commented on 2015-11-08 14:30

Hi there,
I agree with enjoyaol, the short fix should be adapted by the packaging.
Btw, thank you very much Cardiel.