Package Details: ferdi 5.5.0-10

Git Clone URL: https://aur.archlinux.org/ferdi.git (read-only, click to copy)
Package Base: ferdi
Description: A messaging browser that allows you to combine your favorite messaging services into one application
Upstream URL: https://getferdi.com
Keywords: app browser franz gmail messenger slack whatsapp
Licenses: Apache
Submitter: AG_Caesar
Maintainer: dpeukert
Last Packager: dpeukert
Votes: 12
Popularity: 0.064756
First Submitted: 2019-09-25 13:30
Last Updated: 2021-05-29 00:17

Pinned Comments

dpeukert commented on 2021-04-25 14:33

Just a heads-up, gulp-sass (one of the dependencies of this package) doesn't yet support nodejs>=16.0.0, see issues #785 and #797 for more details. I've downgraded the dependency to nodejs 14.x.x (nodejs-lts-fermium) for now.

dpeukert commented on 2020-02-16 11:54

The PKGBUILD for this package is hosted here (contributions are welcome!): https://gitlab.com/dpeukert/pkgbuilds/tree/main/ferdi

Latest Comments

1 2 3 4 Next › Last »

laarSn commented on 2021-06-01 03:12

@dpeukert

re ferdi & ferdi-git: clean build install WORKS OK (Regular package, zen kernel)

re ferdi-bin taskebar icon: let this go, i think it's on my machine side, (bin package zen kernel lightdm cinnamon if you want to reproduce)

Thanks for your work, this app port is a must have!

dpeukert commented on 2021-05-29 00:45

@laarSn

re ferdi & ferdi-git: I've updated patches for both, let me know if that fixed it for you.

re ferdi-bin taskbar icon: That's weird, it's working for me. Can you tell me what DE/WM you're using?

laarSn commented on 2021-05-27 04:29

FIX PLEASE (both git/regular fail) or give solution...downgrade,bin package (also no applet with bin version in taskbar)????

patching file src/stores/AppStore.js Hunk #1 FAILED at 36. 1 out of 1 hunk FAILED -- saving rejects to file src/stores/AppStore.js.rej ==> ERREUR : Une erreur s’est produite dans prepare(). Abandon…

dpeukert commented on 2021-05-03 08:31

@xerus: Nope, that's because ferdi refuses to build with npm >= 7. It's just a build dep though, so you can go back to the your regular npm version once you install this package.

I'll also switch this package to depend on nodejs-lts-fermium as I did with ferdi-git, so that there's no need to downgrade nodejs.

xerus commented on 2021-05-03 08:05

@dpeukert is this why it depends on npm6 rather than npm, forcing me to downgrade?

dpeukert commented on 2021-04-25 14:33

Just a heads-up, gulp-sass (one of the dependencies of this package) doesn't yet support nodejs>=16.0.0, see issues #785 and #797 for more details. I've downgraded the dependency to nodejs 14.x.x (nodejs-lts-fermium) for now.

CodingCellist commented on 2021-04-21 08:25

Yes, it seems to build without problems now. Thanks for fixing things!

dpeukert commented on 2021-04-18 14:28

@CodingCellist @dragonek93: The package should work correctly now, let me know if you run into any other issues.

dragonek93 commented on 2021-04-04 05:56

i got this error when i try to install ferdi or franz: Need to install the following packages: lerna Ok to proceed? (y) y npm WARN deprecated har-validator@5.1.5: this library is no longer supported npm WARN deprecated request@2.88.2: request has been deprecated, see https://github.com/request/request/issues/3142 lerna notice cli v4.0.0 lerna info versioning independent lerna info bootstrap root only npm ERR! code ERESOLVE npm ERR! ERESOLVE unable to resolve dependency tree npm ERR! npm ERR! Found: react-dom@16.12.0 npm ERR! node_modules/react-dom npm ERR! react-dom@"16.12.0" from the root project npm ERR! npm ERR! Could not resolve dependency: npm ERR! peer react-dom@"16.7.0" from forms@1.1.0 npm ERR! packages/forms npm ERR! npm ERR! Fix the upstream dependency conflict, or retry npm ERR! this command with --force, or --legacy-peer-deps npm ERR! to accept an incorrect (and potentially broken) dependency resolution. npm ERR! npm ERR! See /home/dragonek/.cache/paru/clone/ferdi/src/ferdi-5.5.0-8-home/.npm/eresolve-report.txt for a full report.

npm ERR! A complete log of this run can be found in: npm ERR! /home/dragonek/.cache/paru/clone/ferdi/src/ferdi-5.5.0-8-home/.npm/_logs/2021-04-04T05_53_24_354Z-debug.log lerna ERR! npm install exited 1 in 'ferdi' lerna ERR! npm install exited 1 in 'ferdi' ==> BŁĄD: Wystąpił błąd w prepare(). Przerywam... :: Packages failed to build: ferdi-5.5.0-8

CodingCellist commented on 2021-03-26 16:19

I am unsure if this is NPM's fault or Ferdi's, but I get the following error when trying to build after a fresh install of Arch:

npm ERR! code ERESOLVE
npm ERR! ERESOLVE unable to resolve dependency tree
npm ERR! 
npm ERR! Found: react-dom@16.12.0
npm ERR! node_modules/react-dom
npm ERR!   react-dom@"16.12.0" from the root project
npm ERR! 
npm ERR! Could not resolve dependency:
npm ERR! peer react-dom@"16.7.0" from forms@1.1.0
npm ERR! packages/forms
npm ERR! 
npm ERR! Fix the upstream dependency conflict, or retry
npm ERR! this command with --force, or --legacy-peer-deps
npm ERR! to accept an incorrect (and potentially broken) dependency resolution.

In case it's relevant, I'm using npm 7.7.5, electron8-bin, and nodejs 15.12.0. Any help would be much appreciated :)