Package Details: feedreader-git 2.9.2.r2884-1

Git Clone URL: https://aur.archlinux.org/feedreader-git.git (read-only)
Package Base: feedreader-git
Description: FeedReader is a modern desktop application designed to complement existing web-based RSS accounts.
Upstream URL: https://github.com/jangernert/FeedReader
Keywords: atom feed feedreader reader rss tt-rss
Licenses: GPL3
Conflicts: feedreader
Provides: feedreader
Submitter: horosgrisa
Maintainer: asm0dey
Last Packager: asm0dey
Votes: 20
Popularity: 0.022648
First Submitted: 2016-02-04 17:35
Last Updated: 2019-09-02 07:15

Latest Comments

« First ‹ Previous 1 2 3 4

dsboger commented on 2016-05-17 01:41

Please, add a pkgver() function that generates a version number from the current state of the repository, like these guidelines: https://wiki.archlinux.org/index.php/VCS_package_guidelines#Git

It makes easier to know how recent is the version we are using (for bug reports, for example).

Thanks!

horosgrisa commented on 2016-02-15 12:17

@Se7enTime Now feedreader don't depend on libunity.

Se7enTime commented on 2016-02-15 01:10

how to disable libunity dependency and build feedreader-git without it?

horosgrisa commented on 2016-02-05 07:31

@TrialnError Thank you

TrialnError commented on 2016-02-04 19:35

Replaces isn't used in this context. This job is done by Conflicts and provides, which are set in the PKGBUILD.
So please remove the replaces line

scujas commented on 2015-09-06 11:29

I updated your PKGBUILD to use the stable version of FeedReader. CMAKE is set to build without libunity, so its dependency's are removed.

Here is the Pastebin: http://pastebin.com/DNxLFJbj

It builds successfully, so feel free to use it...

JeanLuc commented on 2015-09-02 12:02

Just a heads up:
You don't need to replace the webkit version in the build script anymore. There is a build switch now ;)
Just append "-DUSE_WEBKIT_4=ON" to the cmake command.
Also there is a stable branch now. So no need for unstable anymore ;) (lp:feedreader/1.2)

tydell commented on 2015-04-22 03:52

Actually I must say I don't see any problems using python-html2text package, feedreader works for me very well and I don't have issue you described. I will investigate this and try to make some compromise, for now I changed dependencies form python-html2text package to html2text-with-ut8, but when I would find any problems then I will change it back to python-html2text as it could be find in official repos.

SB_1611 commented on 2015-04-21 14:56

Using FeedReader with Feedly (and maybe with other sources), FeedReader never actually passes the loading screen.

Enabling the DEBUG mode in dconf-editor shows that feedreader-daemon is in a loop forever throwing the following error:

html2text: error: no such option: -u

After opening a bug in Launchpad and talking with the developer (https://bugs.launchpad.net/feedreader/+bug/1446294), it seems that this comes down to a packaging error, since "python-html2text" is listed as a dependency in the PKGBUILD and not the actual html2text binary (http://www.mbayer.de/html2text/index_de.shtml).

However, I couldn't find an official html2text package in the repos, but there is an "html2text-with-utf8" package in the AUR. Changing the dependency in the PKGBUILD and building with that works and FeedReader actually loads all the feeds.

I have no idea why there is no simple "html2text" package in the repos, but I would appreciate it if you could for now change the dependency from "python-html2text" to "html2text-with-utf8".