Package Details: fdroidcl 0.5.0-2

Git Clone URL: https://aur.archlinux.org/fdroidcl.git (read-only)
Package Base: fdroidcl
Description: F-Droid desktop client
Upstream URL: https://github.com/mvdan/fdroidcl
Licenses: BSD
Submitter: mvdan
Maintainer: mvdan
Last Packager: mvdan
Votes: 5
Popularity: 0.029251
First Submitted: 2016-09-12 14:35
Last Updated: 2019-09-28 12:51

Latest Comments

mvdan commented on 2019-09-28 12:48

Apologies, I completely missed your comment. I'll fix both issues, thanks.

Note that Go 1.13 only requires -trimpath to properly produce reproducible binaries, in theory. There's a minor bug with that, but it's already fixed in 1.13.2, which should come out in a few days. So I won't add the rest of the all= flags as they won't be necessary soon enough.

Mouath commented on 2019-07-12 18:35

Would you mind striping the binaries to avoid warning like this: ==> WARNING: Package contains reference to $srcdir usr/bin/fdroidcl

also installing zsh completion from contrib.

here;s a patch from https://wiki.archlinux.org/index.php/Go_package_guidelines

Thanks.

diff --git a/PKGBUILD b/PKGBUILD
index 54b9866..8eaed2c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -21,11 +21,16 @@ prepare() {

 build() {
    cd "${srcdir}/src/mvdan.cc/${_name}"
-   GOPATH="${srcdir}" go build -ldflags='-s -w'
+    GOPATH="${srcdir}" go build \
+    -gcflags "all=-trimpath=${PWD}" \
+    -asmflags "all=-trimpath=${PWD}" \
+    -ldflags "-s -w -extldflags ${LDFLAGS}" \
+    .
 }

 package() {
    cd "${srcdir}/src/mvdan.cc/${_name}"
    install -Dm755 "${_name}" "${pkgdir}/usr/bin/${_name}"
    install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+    install -Dm644 contrib/completion/zsh/_fdroidcl "${pkgdir}/usr/share/zsh/vendor-completions/_fdroidcl"
 }

mvdan commented on 2019-02-19 11:53

Line 19 of the PKGBUILD needs to be changed to

Did you encounter an error, or is this just about correctness? Both forms seem fine to me, and the current PKGBUILD works.

And it depends to go>=1.11, so e.g. the current gcc-go does not work, you have to have go installed.

Won't that be too restrictive? Future gcc-go versions will support the Go 1.11 language and standard library, so I don't want to forbid those.

jeythekey commented on 2019-02-18 20:39

And it depends to go>=1.11, so e.g. the current gcc-go does not work, you have to have go installed.

jeythekey commented on 2019-02-18 20:37

Line 19 of the PKGBUILD needs to be changed to

mv "${_name}" "src/mvdan.cc/"

mvdan commented on 2017-04-19 20:15

@Nanoseb thanks, done.

Nanoseb commented on 2017-04-19 19:56

adb is needed, hence the package 'android-tools' shoud be set as a dependency.