Package Details: fakturama 2.1.0.e-3

Git Clone URL: https://aur.archlinux.org/fakturama.git (read-only, click to copy)
Package Base: fakturama
Description: Creates invoices with ZUGFeRD support
Upstream URL: https://www.fakturama.info
Keywords: bill billing faktura invoice rechnung zugferd
Licenses: EPL
Submitter: Helloagain
Maintainer: Helloagain
Last Packager: Helloagain
Votes: 1
Popularity: 0.116270
First Submitted: 2018-07-24 18:08
Last Updated: 2020-07-08 11:32

Latest Comments

Helloagain commented on 2020-07-08 11:38

  • I added a cleanup script for features/ and plugins/ sub directories on upgrades
  • I fixed the ugly permissions from version 2.1.0.e-2
  • I added a second desktop shortcut for starting the application in clean-mode

I hope this solves the problems. Unfortunately I cannot reproduce the error anymore...

steadfasterX commented on 2020-07-07 14:07

I get the same spinner but you can still type in that field and it works, lol.. will ask him..

Helloagain commented on 2020-07-07 11:40

Unfortunately I cant answer in the forum anymore to ask for details. I only get a spinner instead of a textfield (either in Firefox and in Chrome, with adblocker disabled).

Can you get a list of files that should be deleted upon upgrade? I can then incorporate it into the PKGBUILD in pre_upgrade to get these files delted before upgrade (and get rid of these ugly permission hacks) - so it should work then until it fixed at some point upstream...

steadfasterX commented on 2020-07-07 06:54

well tbh I saw these permission changes you did but they were not set on mine after the upgrade. So I had set them manually as you did on the PKGBUILD but it had no effect so I opened the case in the forum I linked.. as you can see he reviewed my log and it was absolutely clear for him what causes the issues and as said after deleting and re-installing everything went fine.. maybe both are needed the permission changes + the cleanup of the old libs.. because now after a fresh install the permissions are set as they are defined in the PKGBUILD

Helloagain commented on 2020-07-06 19:29

Yes, that was the exact same symptoms I saw. I thought I fixed it with the permissions - at least I could (reproducibly!) fix it on my machine with it ...

steadfasterX commented on 2020-07-06 19:16

its related to this post @Helloagain:

https://www.fakturama.info/community/fehler-verbesserungsvorschlaege/fakturama-startet-aber-leer-ohne-layout-keine-moeglichkeit-menues-zu-benutzen/

Helloagain commented on 2020-07-06 19:14

Thanks for the report. I think it might be related to this issue I reported:

https://www.fakturama.info/community/postid/14964/

I tried to fix it with giving (more) extensive permissions on the install. I hope it will get fixed soon, so I can revert this in the PKGBUILD. With that fix it started on my system at least.

(PKGBUILD lines 55 and 67-70, https://aur.archlinux.org/cgit/aur.git/tree/PKGBUILD?h=fakturama&id=5abdbf16c599a72a51853f0811db681f8ac9e9bd)

steadfasterX commented on 2020-07-06 19:04

upgrading from 2.1.0-c will lead into a starting but unusable install: https://www.fakturama.info/wp-content/uploads/wpforo/default_attachments/1593532158-2020-06-30_17-31.png

the reason is that there are library incompatibilities which do not get cleaned up by the installer correctly.

fix: uninstall and re-install to clear the incompat libs.

note: reported upstream already and the dev said it will be fixed asap.