Package Details: f3 7.2-1

Git Clone URL: https://aur.archlinux.org/f3.git (read-only)
Package Base: f3
Description: Utilities to detect and repair counterfeit flash storage, i.e. thumb drives and memory cards with less flash than advertised
Upstream URL: http://oss.digirati.com.br/f3/
Licenses: GPL3
Submitter: kyle
Maintainer: yaakushi
Last Packager: yaakushi
Votes: 58
Popularity: 0.486393
First Submitted: 2015-08-15 22:39
Last Updated: 2019-08-05 19:38

Latest Comments

1 2 Next › Last »

yaakushi commented on 2019-08-11 16:30

@gerega: Do you have the base-devel group package installed? base-devel is assumed to be installed for all AUR packages (https://wiki.archlinux.org/index.php/Arch_User_Repository#Getting_started). If you do have base-devel installed in your system, are you trying to use another compiler (e.g. clang)?

gerega commented on 2019-08-11 11:02

==> Begin build()... cc -std=c99 -Wall -Wextra -pedantic -MMD -ggdb -c -o utils.o utils.c make: cc: command not found make: *** [<eingebaut>: utils.o] error 127 ==> ERROR: An error happened in build(). Stopping... ==> ERROR:Makepkg could not create f3.

(Translated some words from german to english, maybe it is written a little bit different in an english terminal)

Thanx a lot for your work yaakushi!

yaakushi commented on 2019-08-05 19:34

I adopted this package a few days ago and I'm (finally) bumping the version of the package to match the upstream. Anyway, libgudev doesn't seem to be mentioned anywhere in the documentation, so I'll assume it was a typo and yochananmarqos meant to say libudev. libudev is provided by systemd-libs, which is a dependency of one of the packages in the base group, so I don't think it needs to be explicit on the PKGBUILD. Feel free to let me know if I'm wrong.

yochananmarqos commented on 2019-02-08 15:14

You're missing the libgudev dependency for f3probe and f3brew. See the documentation.

kyle commented on 2018-11-07 15:13

I apologize for the long delay ... I've bumped the package version.

Kppqju77 commented on 2018-10-22 22:49

For the update, https://gist.github.com/juadde/8fab9507355386fd7c63065ab4ce1363 seems to work well for me.

uberben commented on 2018-09-15 17:51

Looks like 7.1 came out in July: https://github.com/AltraMayor/f3/releases/tag/v7.1

kyle commented on 2016-02-01 22:03

Fixed. Thanks for the patch.

z3ntu commented on 2016-02-01 18:46

==> ERROR: conflicts should be an array
==> ERROR: provides should be an array

https://gist.github.com/z3ntu/4c37faee2c3257629681 <- this patch fixes it

mib1982 commented on 2016-01-05 23:21

Yes, sorry, that previous PKGBUILD I pasted did not work.
The following PKGBUILD does build for me: http://pastebin.com/s32DCT2d