Package Details: exfalso 4.2.1-1

Git Clone URL: https://aur.archlinux.org/exfalso.git (read-only)
Package Base: exfalso
Description: GTK+ audio tag editor
Upstream URL: https://quodlibet.readthedocs.io/
Licenses: GPL2
Conflicts: quodlibet
Submitter: rscholer
Maintainer: Archange (rscholer)
Last Packager: Archange
Votes: 91
Popularity: 0.92
First Submitted: 2008-08-10 21:32
Last Updated: 2019-11-15 16:27

Pinned Comments

Archange commented on 2016-05-04 09:24

If you face this:
==> Verifying source file signatures with gpg...
quodlibet-x.y.z.tar.gz ... FAILED (unknown public key 5A62D0CAB6264964)
==> ERROR: One or more PGP signatures could not be verified!
==> ERROR: Makepkg was unable to build exfalso.

Please read this:
https://wiki.archlinux.org/index.php/Makepkg#Signature_checking

Or use the following to build (but doing so means reduced security, you should only do that if you know what you’re doing):
makepkg -s --skippgpcheck

Latest Comments

1 2 3 4 5 6 Next › Last »

gbernard commented on 2019-11-18 10:10

Thank you for the fix. Better health for you, rscholer.

Archange commented on 2019-11-15 16:27

Thanks, an interesting error that existed for years but was only catched by the new checks in pacman 5.2. Fixed and pushed.

rscholer commented on 2019-11-15 15:13

@gbernard:

I'm currently in a hospital without access to my laptop. I should be able to fix this around the beginning/middle of December.

Sorry for the inconvenience.

gbernard commented on 2019-11-15 14:40

ERROR :

$ makepkg -Cc --skippgpcheck ==> ERROR: conflicts is not allowed to be empty.

patch ?

--- PKGBUILD.old    2019-11-15 15:38:43.927638423 +0100
+++ PKGBUILD    2019-11-15 15:38:49.294360217 +0100
@@ -15,7 +15,7 @@
             'kakasi: for "Kana/Kanji Simple Inverter" plugin'
             'python-dbus: for "Browse Folders" plugin'
             'python-musicbrainzngs: for "MusicBrainz Lookup" plugin')
-conflicts=("${pkgbase}")
+conflicts=("${_pkgbase}")
 source=("https://github.com/${_pkgbase}/${_pkgbase}/releases/download/release-${pkgver}/${_pkgbase}-${pkgver}.tar.gz"{,.sig})
 sha256sums=('c68d5c8aa7ffae514f878a1b52a769558974ae3cfc53c2c892efdf98528ac470'
             'SKIP')

after all is good :

$ makepkg -Cc --skippgpcheck ... ==> Tidying install... -> Removing libtool files... -> Purging unwanted files... -> Removing static library files... -> Stripping unneeded symbols from binaries and libraries... -> Compressing man and info pages... ==> Checking for packaging issues... ==> Creating package "exfalso"... -> Generating .PKGINFO file... -> Generating .BUILDINFO file... -> Generating .MTREE file... -> Compressing package... ==> Leaving fakeroot environment. ==> Finished making: exfalso 4.2.0-1 (Fri 15 Nov 2019 03:39:59 PM CET) ==> Cleaning up...

FichteFoll commented on 2017-08-04 18:10

The program doesn't launch without the "optional" dependency python-dbus.

Traceback (most recent call last):
File "/usr/lib/python3.6/site-packages/quodlibet/qltk/session.py", line 23, in init
bus = dbus.Bus(dbus.Bus.TYPE_SESSION)
AttributeError: module 'dbus' has no attribute 'Bus'

rscholer commented on 2017-05-28 20:04

ArchangeGabriel: Aaaargh! I got mixed-up with another plugin. I readded the "MusicBrainz Lookup" plugin and corresponding optdepends, also the "covers" package is now removed, as well as two other overlooked plugins.

I hope there wasn't another mix-up.

Archange commented on 2017-05-28 19:22

I think MusicBrainz will require the corresponding python-package. ;)

rscholer commented on 2017-05-28 19:20

Plugins are included again as of 3.9.0-2.

Excluded plugins fall in at least one of the following categories:
- Plugins not shown in Ex Falso's plugin manager.
- Plugins depending on Quod Libet's database or on built-in playback functionality.
- Plugins that have no functionality.

Please leave a comment if you encounter issues or want to argue for the inclusion/exclusion of a plugin.

rscholer commented on 2017-05-28 15:02

ArchangeGabriel: Thanks. PKGBUILD is updated.

Archange commented on 2017-05-28 14:23

rscholer: Added you as comaintainer. You can apply your patch, but no need to bump pkgrel: nothing changed regarding the resulting package, people having already updated don’t need to rebuild. ;)