Package Details: evdi 1.7.0-2

Git Clone URL: https://aur.archlinux.org/evdi.git (read-only, click to copy)
Package Base: evdi
Description: A Linux® kernel module that enables management of multiple screens.
Upstream URL: https://github.com/DisplayLink/evdi
Licenses: GPL
Submitter: PlusMinus
Maintainer: mwawrzyniak
Last Packager: mwawrzyniak
Votes: 39
Popularity: 0.62
First Submitted: 2016-09-16 07:44
Last Updated: 2020-10-18 14:58

Pinned Comments

mwawrzyniak commented on 2020-10-18 15:02

I have downgraded this package to v1.7.0 and applied the patch from abucodonosor to let it compile on kernel version 5.9.

Please note sickcodes' comment about removing /etc/udev/rules.d/99-displaylink.rules if you have issues with X crashing.

Once the new versions of DisplayLink are available which use evdi > 1.7.0, I will switch back to keeping this package up-to-date with upstream.

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 10 11 ... Next › Last »

darose commented on 2019-03-14 04:16

Works fine over here. Do you have the linux-headers package installed?

BoredCat commented on 2019-03-14 00:14

Fails to build latest kernel.

Your kernel headers for kernel 5.0.0-arch1-1-ARCH cannot be found at /usr/lib/modules/5.0.0-arch1-1-ARCH/build or /usr/lib/modules/5.0.0-arch1-1-ARCH/source.

error: command failed to execute correctly

BoredCat commented on 2019-03-14 00:13

Fails to build latest Kernel

Your kernel headers for kernel 5.0.0-arch1-1-ARCH cannot be found at /usr/lib/modules/5.0.0-arch1-1-ARCH/build or /usr/lib/modules/5.0.0-arch1-1-ARCH/source. error: command failed to execute correctly

mwawrzyniak commented on 2018-12-28 13:37

You can ignore that error, it's always done that. The module still gets built and still works.

I will be doing some higher-level maintenance of the PKGBUILD at some point to get rid of some of these errors.

noraj commented on 2018-12-28 08:48

install of evdi seems correct now https://pastebin.com/qcgxTX1D

BUT in reality the build failed:

Something like:

ERROR: Kernel configuration is invalid.
include/generated/autoconf.h or include/config/auto.conf are missing.
Run 'make oldconfig && make prepare' on kernel src to fix it.

mwawrzyniak commented on 2018-12-26 19:21

I uploaded a new release to fix building in 4.20 kernels. The error in make.log related to something removed in 4.20 (https://github.com/torvalds/linux/commit/04cfcc7ab358e331b32cabde1e853a125f3f8735#diff-43768cc89c01c730cb119634b42dfa81).

The functionality wasn't apparently stable enough to be worthwhile. Removing it should have no effect on kernels < 4.20 either.

noraj commented on 2018-12-26 15:27

evdi 1.5.1 is not building for 4.20.0 (manjaro) and maybe 4.19.12 (manjaro).

https://pastebin.com/g7C1PGeb

PS : /var/lib/dkms/evdi/1.5.1/build/make.log doesn't exist

wjhandley commented on 2018-11-27 10:26

I needed to install linux-headers (Possibly should add as a dependency)

darose commented on 2018-11-17 16:59

You need to upgrade to v1.5.1

mr.buffed commented on 2018-11-17 13:39

Same problem here as for @darose; cannot build evdi DKMS after upgrade to kernel 4.19.1-arch1-1-ARCH. Downgrading kernel to 4.18.16-arch1-1-ARCH helped.