Package Details: evdi 1.9.1-1

Git Clone URL: https://aur.archlinux.org/evdi.git (read-only, click to copy)
Package Base: evdi
Description: A Linux® kernel module that enables management of multiple screens.
Upstream URL: https://github.com/DisplayLink/evdi
Licenses: GPL
Submitter: PlusMinus
Maintainer: mwawrzyniak
Last Packager: mwawrzyniak
Votes: 42
Popularity: 0.49
First Submitted: 2016-09-16 07:44
Last Updated: 2021-04-27 16:35

Latest Comments

« First ‹ Previous ... 9 10 11 12 13 14

natzei commented on 2017-02-01 22:51

@krupan
Please read the previous comments.
The versions 1.3.42 and 1.3.43 are not stable.

krupan commented on 2017-02-01 22:47

Looks like this is out of date, there is a 1.3.43 release listed here:

https://github.com/DisplayLink/evdi/releases

Maybe that would build fine?

krupan commented on 2017-02-01 22:41

I can confirm that it does not build against 4.9.6. Here's the error message:

/var/lib/dkms/evdi/1.2.64/build/evdi_connector.c: In function ‘evdi_connector_init’:
/var/lib/dkms/evdi/1.2.64/build/evdi_connector.c:148:24: error: ‘struct drm_mode_config’ has no member named ‘dirty_info_property’; did you mean ‘tile_property’?
dev->mode_config.dirty_info_property, 1);
^
/var/lib/dkms/evdi/1.2.64/build/evdi_modeset.c: In function ‘evdi_modeset_init’:
/var/lib/dkms/evdi/1.2.64/build/evdi_modeset.c:375:2: error: implicit declaration of function ‘drm_mode_create_dirty_info_property’ [-Werror=implicit-function-declaration]
drm_mode_create_dirty_info_property(dev);
^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
make[2]: *** [scripts/Makefile.build:293: /var/lib/dkms/evdi/1.2.64/build/evdi_connector.o] Error 1
make[2]: *** Waiting for unfinished jobs....
if [ "-pg" = "-pg" ]; then if [ /var/lib/dkms/evdi/1.2.64/build/evdi_encoder.o != "scripts/mod/empty.o" ]; then ./scripts/recordmcount "/var/lib/dkms/evdi/1.2.64/build/evdi_encoder.o"; fi; fi;
if [ "-pg" = "-pg" ]; then if [ /var/lib/dkms/evdi/1.2.64/build/evdi_drv.o != "scripts/mod/empty.o" ]; then ./scripts/recordmcount "/var/lib/dkms/evdi/1.2.64/build/evdi_drv.o"; fi; fi;
cc1: some warnings being treated as errors
make[2]: *** [scripts/Makefile.build:293: /var/lib/dkms/evdi/1.2.64/build/evdi_modeset.o] Error 1
make[1]: *** [Makefile:1490: _module_/var/lib/dkms/evdi/1.2.64/build] Error 2
make[1]: Leaving directory '/usr/lib/modules/4.9.6-1-ARCH/build'
make: *** [Makefile:21: all] Error 2

truongan commented on 2017-01-29 05:53

Doesn't seem to work with the latest 4.9.6 kernel updated yesterday

PlusMinus commented on 2017-01-25 13:58

You are right, of course, but the person flagging this out of date could have checked as well.

natzei commented on 2017-01-25 11:10

Hi PlusMinus,
the last update of the package does not work correctly.
The problem is that you are distributing a devel release, as explained in this issue https://github.com/DisplayLink/evdi/issues/74#issuecomment-275076321

Please downgrade to the latest master release v1.2.64.
For the future, please check if the release is done under the master branch.

Thank you

PlusMinus commented on 2016-11-29 10:23

They are optional dependencies for dkms, I suppose the reason is that you can have different kernels and therefore can't be sure which headers are needed.

vincele commented on 2016-11-26 08:27

Looks like there's a missing dependency: linux-headers
see last comment on : https://aur.archlinux.org/packages/displaylink/

Maybe this dep should be added to dkms itself, dunno...

PlusMinus commented on 2016-09-16 08:53

Upstream releases are a little slow. Next time this package breaks I might create an evdi-git package.