Package Details: etlegacy-git 2.76.810.g164b964c3-1

Git Clone URL: https://aur.archlinux.org/etlegacy-git.git (read-only, click to copy)
Package Base: etlegacy-git
Description: Wolfenstein: Enemy Territory 2.60b compatible client/server (etlegacy engine)
Upstream URL: http://etlegacy.com/
Licenses: GPL3
Conflicts: etlegacy
Provides: etlegacy
Submitter: vorot93
Maintainer: The_Loko
Last Packager: The_Loko
Votes: 6
Popularity: 1.03
First Submitted: 2015-08-09 16:19
Last Updated: 2020-02-09 19:33

Dependencies (30)

Required by (0)

Sources (1)

Latest Comments

MartinX3 commented on 2021-04-22 20:10

I can't find it in the app list and need to start it manually in the terminal with "/usr/bin/etl"

PongTea commented on 2020-11-22 16:24

FYI package compiles successfully but there is an issue affecting only 64bit patched clients (above v.2.76).

TL;DR: 64bit patched client need to connect to a patched server.

Details: quoting upstream

[...]in case you will attempt to connect to 2.76 server [with a patched client] and be forced to download the 2.76 paks, you will run into the issue [which is game crash]. There is nothing to do about it, you can instead compile or use 32 bit executable, since the problem only affects 64bit binaries.

And also, quoting upstream

Currently only official and one custom server https://et.trackbase.net/server/45410 supports patched binary.

Awebb commented on 2020-08-31 05:28

Your prepare function messes with $HOME. This shouldn't ever happen.

StormEngineer commented on 2020-07-15 16:27

Depends on lua 5.4+ but Arch only has 5.3 ???

niezniszczalny commented on 2020-03-13 23:27

After installation and running game I get no graphical interface: https://pastebin.com/DM0sWg6G

Also, very scarce '.etwolf' directory is created with only one file 'etkey' in 'main' and 'ui.mp.x86_64.so' in 'legacy' directiories.

dobo commented on 2020-02-14 23:02

Is there any reason why ui.mp.x86_64.so isn't copied to /usr/lib/etlegacy/legacy directory? Without copying this manually, game doesn't start for me: 0 Sys_LoadDll(/usr/lib/etlegacy/legacy/ui.mp.x86_64.so)... 0 failed: /usr/lib/etlegacy/legacy/ui.mp.x86_64.so: cannot open shared object file: No such file or directory 0 Sys_LoadDll(/home/dobo/.etlegacy/legacy/ui.mp.x86_64.so)... 0 failed: /home/dobo/.etlegacy/legacy/ui.mp.x86_64.so: undefined symbol: __acosf_finite 0 Sys_LoadDll(legacy/ui) failed to load library

niezniszczalny commented on 2018-03-25 21:02

I'm getting a message:

Sys_LoadDll(/usr/lib/etlegacy/legacy/ui.mp.x86_64.so)... failed: "Failed loading /usr/lib/etlegacy/legacy/ui.mp.x86_64.so: /usr/lib/etlegacy/legacy/ui.mp.x86_64.so: cannot open shared object file: No such file or directory"

I've found ui.mp.x86_64.so in /home/niezniszczalny/.etlegacy/legacy/ but when I copy it to /usr/lib/etlegacy/legacy the ET:L doesn't have permissions to use that file. Any idea what to do?

[edit]

I've just changed permissions using chmod. I'm not getting this message anymore.

The_Loko commented on 2016-06-27 12:40

Alad > It works if you add "git submodule update --init --recursive" on prepare function, as etlegacy git repo keeps libraries on submodules.

Alad commented on 2016-03-25 23:25

-- Configuring done
CMake Error at cmake/ETLInstallLuaSQL.cmake:41 (add_library):
Cannot find source file:

/home/aur/etlegacy-git/src/etlegacy/libs/luasql/src/luasql.h

Tried extensions .c .C .c++ .cc .cpp .cxx .m .M .mm .h .hh .h++ .hm .hpp
.hxx .in .txx
Call Stack (most recent call first):
CMakeLists.txt:180 (include)


CMake Error: CMake can not determine linker language for target: luasql_library_module
CMake Error: Cannot determine link language for target "luasql_library_module".
-- Generating done
-- Build files have been written to: /home/aur/etlegacy-git/src/etlegacy
==> ERROR: A failure occurred in build().
Aborting...

StormEngineer commented on 2015-11-12 17:11

Hi! Last time I built a few weeks ago, both "etlegacy32-git" and "etlegacy32-mod-git" depended on "lib32-libtheora" but it was not listed as a dependency and build failed without it.