Package Details: etherpad-lite 1:1.8.0-1

Git Clone URL: (read-only, click to copy)
Package Base: etherpad-lite
Description: Lightweight fork of etherpad based on javascript
Upstream URL:
Licenses: Apache
Conflicts: etherpad-lite-git
Submitter: onny
Maintainer: dvzrv
Last Packager: dvzrv
Votes: 28
Popularity: 0.000044
First Submitted: 2013-03-15 15:10
Last Updated: 2019-12-09 12:58

Pinned Comments

dvzrv commented on 2019-02-10 17:17

The upgrade to 1.7.5 brought a lot of security fixes. Please upgrade! The custom directory in /etc/etherpad-lite was replaced by no-skin, introducing a new skin system. The credentials.json file was added and can be used to setup credentials as well.

dvzrv commented on 2017-12-22 16:18

I updated to 1.6.2.

Please note: From now on, etherpad-lite is relying on systemd-tmpfiles and systemd-sysusers and the setting of a dynamic StateDirectory according to its service file. The scripts delivered by upstream are no longer run.

These new features make the package more secure, but the new way of installing it also renders its content static (i.e. the installation of plugins is currently not possible, as the installation folder is now owned by root).

Before the included npm package had the possibility to install all over the install directory, leading to folders and files not taken care of or cleaned up by pacman.

Although the new state is somewhat unfortunate, I hope you can appreciate it nonetheless from a viewpoint of this now being a "clean(er) install".

I referred to upstream about the changes to maybe inspire a change in the way plugins should be installed to a dedicated (settable) directory.

The way etherpad-lite is installed now is still far from being perfect.

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 ... Next › Last »

schimicata commented on 2016-12-02 13:00

For sudo -u etherpad /usr/share/webapps/etherpad-lite/bin/ I'll get following errors and etherpad doesn't start up.

RubenKelevra commented on 2016-12-01 20:27

Just to be clear, on this update, the warnings might still appear, because the checks are done previously before upgrading.

smithinger44 commented on 2016-11-26 23:05

npm returns so many warnings during installation:

PetaByteBoy commented on 2016-11-11 08:57

@RubenKelevra compatibility issues with nodejs >= 7.0

RubenKelevra commented on 2016-06-15 04:56

Thanks for your hint.

schimicata commented on 2016-06-10 10:20

@RubenKelevra: Yaourt doesn't see the newer version of etherpad-lite, so it doesn't upgrade it automatically. Is it because in v1:1.5.7-3 there was "epoch=1" in PKGBUILD and now it's "#epoch=1" --> thus epoch=0 ?

RubenKelevra commented on 2016-06-07 13:02

@dvzrv sorry for the delayed releases, but I test every release some days in my environment, since sometimes they are far from stable. I dislike unstable software and don't want to push them to you. :)

dvzrv commented on 2016-05-24 22:35

etherpad-lite 1.6.0 is working with nodejs>=6.2. Version patch now not needed anymore.
Anyone willing to try can makepkg this:

mjob commented on 2016-05-10 18:07

I needed to downgrade to icu 56 (57 is the current version). After this the etherpad service started just fine.

matschi commented on 2016-05-05 16:04

Has Issues with nodejs 6