Package Details: espressomd-git 3.4.dev.r13633.ff32b09e5-1

Git Clone URL: https://aur.archlinux.org/espressomd-git.git (read-only)
Package Base: espressomd-git
Description: ESPResSo is a software package for performing and analyzing Molecular Dynamics simulations.
Upstream URL: http://espressomd.org/wordpress/
Licenses: GPL
Conflicts: espressomd
Provides: espressomd
Submitter: Raketenjoint
Maintainer: Raketenjoint
Last Packager: Raketenjoint
Votes: 0
Popularity: 0.000000
First Submitted: 2019-06-16 21:23
Last Updated: 2019-09-07 20:20

Dependencies (16)

Required by (0)

Sources (1)

Latest Comments

Raketenjoint commented on 2019-09-07 20:24

You are right, that gcc-8 and g++-8 should be used for CUDA as it doesn't support brand new gcc-9. The error message is: /usr/include/c++/9.1.0/bits/stl_function.h(437): error: identifier "__builtin_is_constant_evaluated" is undefined I changed the make parameters accordingly.

You removed all version restrictions on the dependencies. Please not that python-sphinx has an unfixed upstream bug on the latest 2.1.0 release: https://github.com/sphinx-doc/sphinx/issues/6440

hseara commented on 2019-09-05 10:33

Package does not compile, you can use this OKGBUILD instead:

# Maintainer: Raketenjoint <rak.joint@mailbox.org>
pkgname=espressomd-git
pkgver=3.4.dev.r13559.72da9ac0f
pkgrel=1
pkgdesc="ESPResSo is a software package for performing and analyzing Molecular Dynamics simulations."
arch=('x86_64')
url="http://espressomd.org/wordpress/"
license=('GPL')
groups=()
depends=('python'
         'python-numpy'
         'python-opengl'
         'python-sphinx'
         'python-sphinxcontrib-bibtex'
         'python-mdanalysis')
optdepends=('cuda: Build with NVIDIA GPU support'
            'hdf5: File format to store scientific data'
            'hdf5-openmpi: File format to store scientific data (openmpi version)')
makedepends=('git'
             'gcc8'
             'boost'
             'cmake'
             'fftw'
             'openmpi'
             'cython')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
replaces=()
backup=()
options=()
install=
source=("${pkgname%-git}::git+https://github.com/espressomd/espresso.git")
noextract=()
md5sums=('SKIP')


# Use gcc8 to allow the installation to cuda users
export CXX=g++-8
export CC=gcc-8

# Please refer to the 'USING git SOURCES' section of the PKGBUILD man page for
# a description of each element in the source array.

pkgver() {
        cd "$srcdir/${pkgname%-git}"
        printf "%s" "$(git describe --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
}

prepare() {
        cd "$srcdir/${pkgname%-git}"
}

build() {
        cd "$srcdir/${pkgname%-git}"
        cmake -DCMAKE_INSTALL_PREFIX=/usr .
        make
}
check() {
        cd "$srcdir/${pkgname%-git}"
        make -k check
}

package() {
        cd "$srcdir/${pkgname%-git}"
        make DESTDIR="$pkgdir/" install
}