Package Details: esp-open-sdk-git 1-13

Git Clone URL: https://aur.archlinux.org/esp-open-sdk-git.git (read-only)
Package Base: esp-open-sdk-git
Description: Free and open (as much as possible) integrated SDK for ESP8266 chips
Upstream URL: https://github.com/pfalcon/esp-open-sdk
Keywords: esp esp8266 nonos sdk
Conflicts: esp-open-sdk
Provides: esp-open-sdk
Submitter: sambazley
Maintainer: dini
Last Packager: dini
Votes: 5
Popularity: 0.359670
First Submitted: 2017-07-07 23:39
Last Updated: 2019-04-30 14:56

Latest Comments

1 2 Next › Last »

ksniffer commented on 2019-06-14 13:16

@maxanier thanks

mattiascibien commented on 2019-06-14 06:53

@dini: may I suggest to include the patch here hat can probably fix the _PyImport_FixupBuiltin problem?

https://github.com/thierer/esp-open-sdk/blob/master/1000-gdb-python-3-7.patch

maxanier commented on 2019-06-05 09:55

@ksniffer https://github.com/pfalcon/esp-open-sdk/issues/339

ksniffer commented on 2019-05-24 14:04

[INFO ]  Installing cross-gdb
[ERROR]    /home/ksniffer/tmp/yaourt-tmp-ksniffer/aur-esp-open-sdk-git/src/esp-open-sdk/crosstool-NG/.build/src/gdb-7.10/gdb/python/python.c:1757:3: error: too few arguments to function '_PyImport_FixupBuiltin'
[ERROR]    make[5]: *** [Makefile:2517: python.o] Error 1
[ERROR]    make[4]: *** [Makefile:8755: all-gdb] Error 2
[ERROR]    make[3]: *** [Makefile:845: all] Error 2
[ERROR]   
[ERROR]  >>
[ERROR]  >>  Build failed in step 'Installing cross-gdb'
[ERROR]  >>        called in step '(top-level)'
[ERROR]  >>
[ERROR]  >>  Error happened in: CT_DoExecLog[scripts/functions@257]
[ERROR]  >>        called from: do_debug_gdb_build[scripts/build/debug/300-gdb.sh@120]
[ERROR]  >>        called from: do_debug[scripts/build/debug.sh@35]
[ERROR]  >>        called from: main[scripts/crosstool-NG.sh@646]
[ERROR]  >>
[ERROR]  >>  For more info on this error, look at the file: 'build.log'
[ERROR]  >>  There is a list of known issues, some with workarounds, in:
[ERROR]  >>      'share/doc/crosstool-ng/crosstool-ng-1.22.0-60-g37b07f6f-dirty/B - Known issues.txt'

dini commented on 2019-04-30 14:58

Thx AndrevS.

AndrevS commented on 2019-04-20 15:06

Consider the following patch to make it compile

--- configure.ac.old
+++ configure.ac
@@ -190,7 +190,7 @@ AC_CACHE_VAL([ac_cv_path__BASH],
 AC_CACHE_CHECK([for bash >= 3.1], [ac_cv_path__BASH],
     [AC_PATH_PROGS_FEATURE_CHECK([_BASH], [bash],
         [[_BASH_ver=$($ac_path__BASH --version 2>&1 \
-                     |$EGREP '^GNU bash, version (3\.[1-9]|4)')
+                     |$EGREP '^GNU bash, version (3\.[1-9]|4|5)')
           test -n "$_BASH_ver" && ac_cv_path__BASH=$ac_path__BASH ac_path__BASH_found=:]],
         [AC_MSG_RESULT([no])
          AC_MSG_ERROR([could not find bash >= 3.1])])])

AndrevS commented on 2019-04-05 08:40

I have an error building the package. It cannot find bash >= 3.1 while I have bash 5.0.2 installed

checking for absolute path to patch... /usr/bin/patch
checking for bash >= 3.1... no
configure: error: could not find bash >= 3.1
make[1]: *** [../Makefile:143: _ct-ng] Error 1
make[1]: Leaving directory '/tmp/yaourt-tmp-andre/aur-esp-open-sdk-git/src/esp-open-sdk/crosstool-NG'
make: *** [Makefile:139: crosstool-NG/ct-ng] Error 2

edit: formatting

flaviut commented on 2018-11-06 01:57

I need this patch to reset cflags in order to get this to build:

From 6409f7b16ff0dfa20cf97ffd95af04230d6d44ee Mon Sep 17 00:00:00 2001
From: Flaviu Tamas <tamasflaviu@gmail.com>
Date: Mon, 5 Nov 2018 20:55:55 -0500
Subject: [PATCH] Reset CFLAGS

If cflags are set during the build, the following message is shown:

    [ERROR]  Don't set CXXFLAGS. It screws up the build.
---
 PKGBUILD | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/PKGBUILD b/PKGBUILD
index [`053745e`](https://aur.archlinux.org/cgit/aur.git/commit/?h=esp-open-sdk-git&id=053745e)..57283d4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -32,7 +32,7 @@ prepare() {

 build() {
     cd "$srcdir"/esp-open-sdk
-    LD_LIBRARY_PATH= make
+    LD_LIBRARY_PATH= CFLAGS= CXXFLAGS= make
     cp sdk/lib/libgcc.a xtensa-lx106-elf/lib/gcc/xtensa-lx106-elf/4.8.5
 }

-- 
2.19.1

sambazley commented on 2018-05-18 22:26

Works fine for me. I do however get that error if I clone the repo without --recursive. If you clone correctly, the only change you should need to make is to replace esptool.py with esptool in parameters.mk

eimis commented on 2018-05-18 17:31

not working with esp-open-rtos https://bpaste.net/show/bbcd7ebc76f7