Package Details: epson-inkjet-printer-escpr2 1.1.2-1

Git Clone URL: https://aur.archlinux.org/epson-inkjet-printer-escpr2.git (read-only, click to copy)
Package Base: epson-inkjet-printer-escpr2
Description: Epson Inkjet Printer Driver 2 (ESC/P-R) for Linux
Upstream URL: http://download.ebz.epson.net/dsc/search/01/search/?OSC=LX
Keywords: EP-50V EP-879A EP-880A EP-881A ET-3700 ET-3750 ET-4750 ET-8700 ET-M1140 ET-M1180 ET-M2140 ET-M3140 ET-M3170 ET-M3180 EW-M630T EW-M670FT L6160 L6170 L6190 M1180
Licenses: GPL2
Submitter: AngryUbuntuNerd
Maintainer: AngryUbuntuNerd
Last Packager: AngryUbuntuNerd
Votes: 17
Popularity: 0.39
First Submitted: 2017-12-12 20:15
Last Updated: 2019-10-23 20:29

Pinned Comments

bwrsandman commented on 2019-01-25 16:06

Just a suggestion: could you add the following keywords to the package, it will make finding the package for specific printers easier:

EP-50V Series, EP-879A Series, EP-880A Series, EP-881A Series, ET-3700 Series, ET-3750 Series, ET-4750 Series, ET-8700 Series, ET-M1140 Series, ET-M1180 Series, ET-M2140 Series, ET-M3140 Series, ET-M3170 Series, ET-M3180 Series, EW-M630T Series, EW-M670FT Series, L6160 Series, L6170 Series, L6190 Series, M1180 Series, M2140 Series, M3180 Series, PM-520 Series, PX-M380F, PX-M381FL, PX-M5080F Series, PX-M5081F Series, PX-M680F Series, PX-M7070FX, PX-M7110F, PX-M7110FP, PX-M780F Series, PX-M781F Series, PX-M880FX, PX-M884F, PX-M886FL, PX-S380, PX-S381L, PX-S5010 Series, PX-S5080 Series, PX-S7070X, PX-S7110, PX-S7110P, PX-S880X, PX-S884, WF-2860 Series, WF-3720 Series, WF-3730 Series, WF-4720 Series, WF-4730 Series, WF-4740 Series, WF-7210 Series, WF-7710 Series, WF-7720 Series, WF-C5210 Series, WF-C5290 Series, WF-C5290BA, WF-C529R Series, WF-C529RB, WF-C5710 Series, WF-C5790 Series, WF-C5790BA, WF-C579R Series, WF-C579RB, WF-C8190 Series, WF-C8190B, WF-C8610 Series, WF-C8690 Series, WF-C8690B, WF-C869R Series, WF-M5298 Series, WF-M5299 Series, WF-M5799 Series, XP-15000 Series, XP-5100 Series, XP-6000 Series, XP-6100 Series, XP-8500 Series

Latest Comments

1 2 3 4 5 Next › Last »

BIllzargo commented on 2019-10-23 06:42

This is not working

curl: (22) The requested URL returned error: 404 Not Found ==> ERROR: Failure while downloading

https://download3.ebz.epson.net/dsc/f/03/00/09/72/04/c6d928e83e558c4ba1e7e8bcb5c1fe080b8095eb/epson-inkjet-printer-escpr2-1.1.1-1lsb3.2.src.rpm Aborting... Error downloading sources: epson-inkjet-printer-escpr2}}

AngryUbuntuNerd commented on 2019-07-07 11:29

@catlover2: Without knowing the exact (printer-specific) amendments to make, I cant easily integrate this into the PKGBUILD. And even if I did, it could easily change from version to version and make maintenance painful.

I think you should report this upstream to the guys at Epson to add for your specific printer.

catlover2 commented on 2019-06-17 08:23

Dear maintainer,

I recently disovered that the PPD for the Workforce 7710 is missing definitions for some paper sizes that the printer is capable of printing. I'm not sure how many of the PPDs in the package might have similar problems.

I was able to add missing definitions to the PPD for my printer, and I documented my process on the wiki: https://wiki.archlinux.org/index.php/CUPS/Printer-specific_problems#Adding_missing_paper_sizes

If you or somebody else knows more about this, maybe some of these extra definitions could be incorporated into this package?

benv666 commented on 2019-05-29 09:23

rantanplanx's comment worked for me as well, please update the PKGBUILD :)

rantanplanx commented on 2019-05-26 13:45

Driver seems to have been updated. This worked for me:

Change pkgver to 1.0.34

Change source to https://download3.ebz.epson.net/dsc/f/03/00/09/36/03/b63e3de102ff44e2fa4789b6a75e97877f4e0c41/epson-inkjet-printer-escpr2-1.0.34-1lsb3.2.src.rpm

Change first sha256sums to a7f6705df50f3f7a862fadd91e4e65a3f1041f4aa42025c627a5e52d460a8c61

usjonathan commented on 2019-05-16 03:44

I'm still getting an error 404 when installing it:

ERROR: Failure while downloading https://download3.ebz.epson.net/dsc/f/03/00/09/28/13/7f23b5f75b434571f34a32c8f77675b42bdd9888/epson-inkjet-printer-escpr2-1.0.32-1lsb3.2.src.rpm

gavsiu commented on 2019-04-12 05:06

I needed to install this and like lilmike said, 1.0.31 doesn't work.

Edit pkgbuild:

Change pkgver to 1.0.32

Change source to https://download3.ebz.epson.net/dsc/f/03/00/09/28/13/7f23b5f75b434571f34a32c8f77675b42bdd9888/epson-inkjet-printer-escpr2-1.0.32-1lsb3.2.src.rpm

Change first sha256sums to f5b9b0f5f663a8fb66bef9084cf6b93d46ceca728e4feb05fac515ef02b4b2a5

For future versions, new source here http://download.ebz.epson.net/dsc/du/02/DriverDownloadInfo.do?LG2=EN&CN2=&DSCMI=92813&DSCCHK=6791c52c285c2f61cc5c45e8928b3954c629351d

lilmike commented on 2019-02-01 16:50

The download returns error 404. Just FYI.

bwrsandman commented on 2019-01-25 16:06

Just a suggestion: could you add the following keywords to the package, it will make finding the package for specific printers easier:

EP-50V Series, EP-879A Series, EP-880A Series, EP-881A Series, ET-3700 Series, ET-3750 Series, ET-4750 Series, ET-8700 Series, ET-M1140 Series, ET-M1180 Series, ET-M2140 Series, ET-M3140 Series, ET-M3170 Series, ET-M3180 Series, EW-M630T Series, EW-M670FT Series, L6160 Series, L6170 Series, L6190 Series, M1180 Series, M2140 Series, M3180 Series, PM-520 Series, PX-M380F, PX-M381FL, PX-M5080F Series, PX-M5081F Series, PX-M680F Series, PX-M7070FX, PX-M7110F, PX-M7110FP, PX-M780F Series, PX-M781F Series, PX-M880FX, PX-M884F, PX-M886FL, PX-S380, PX-S381L, PX-S5010 Series, PX-S5080 Series, PX-S7070X, PX-S7110, PX-S7110P, PX-S880X, PX-S884, WF-2860 Series, WF-3720 Series, WF-3730 Series, WF-4720 Series, WF-4730 Series, WF-4740 Series, WF-7210 Series, WF-7710 Series, WF-7720 Series, WF-C5210 Series, WF-C5290 Series, WF-C5290BA, WF-C529R Series, WF-C529RB, WF-C5710 Series, WF-C5790 Series, WF-C5790BA, WF-C579R Series, WF-C579RB, WF-C8190 Series, WF-C8190B, WF-C8610 Series, WF-C8690 Series, WF-C8690B, WF-C869R Series, WF-M5298 Series, WF-M5299 Series, WF-M5799 Series, XP-15000 Series, XP-5100 Series, XP-6000 Series, XP-6100 Series, XP-8500 Series

nmiddleton commented on 2019-01-11 14:56

Here's a patch for current version on epson website:

diff --git a/.SRCINFO b/.SRCINFO
deleted file mode 100644
index e7d4c44..0000000
--- a/.SRCINFO
+++ /dev/null
@@ -1,21 +0,0 @@
-pkgbase = epson-inkjet-printer-escpr2
-   pkgdesc = Epson Inkjet Printer Driver 2 (ESC/P-R) for Linux
-   pkgver = 1.0.27
-   pkgrel = 1
-   url = http://download.ebz.epson.net/dsc/search/01/search/?OSC=LX
-   arch = i686
-   arch = x86_64
-   arch = armv6h
-   arch = armv7h
-   license = GPL2
-   depends = cups
-   depends = ghostscript
-   optdepends = imagescan: scanner support
-   options = !libtool
-   source = https://download3.ebz.epson.net/dsc/f/03/00/08/71/45/3c00267c241e8cb90f2167a27c4e9f75828e5e66/epson-inkjet-printer-escpr2-1.0.27-1lsb3.2.src.rpm
-   source = bug_x86_64.patch
-   sha256sums = 21975eaa03c43b07e88223d39eb6df3ca526f22243bc6e373fcc36280607c297
-   sha256sums = 44160b2ef140e97137d65c4db7a50cfe40399ab8691caaeaf43c08f758b8c545
-
-pkgname = epson-inkjet-printer-escpr2
-
diff --git a/PKGBUILD b/PKGBUILD
index ea1a8c1..fbb6b6f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,17 @@
 pkgname=epson-inkjet-printer-escpr2
-pkgver=1.0.27
+pkgver=1.0.28
 pkgrel=1
 pkgdesc="Epson Inkjet Printer Driver 2 (ESC/P-R) for Linux"
-arch=('i686' 'x86_64' 'armv6h' 'armv7h')
+arch=('i686' 'x86_64')
 url="http://download.ebz.epson.net/dsc/search/01/search/?OSC=LX"
 license=('GPL2')
 depends=('cups' 'ghostscript')
 optdepends=('imagescan: scanner support')
 options=('!libtool')
-source=('https://download3.ebz.epson.net/dsc/f/03/00/08/71/45/3c00267c241e8cb90f2167a27c4e9f75828e5e66/epson-inkjet-printer-escpr2-1.0.27-1lsb3.2.src.rpm'
+source=(#'epson-inkjet-printer-escpr2-1.0.28-1lsb3.2.src.rpm'
+   'https://download3.ebz.epson.net/dsc/f/03/00/08/93/16/e484dad0996111ecd76d58de992765967bfe6319/epson-inkjet-printer-escpr2-1.0.28-1lsb3.2.src.rpm'
         'bug_x86_64.patch')
-sha256sums=('21975eaa03c43b07e88223d39eb6df3ca526f22243bc6e373fcc36280607c297'
+sha256sums=('6d1b7253a424be230e1dc12017c7b84a69cd6f2d8649ef468aa1dc84206a27c8'
             '44160b2ef140e97137d65c4db7a50cfe40399ab8691caaeaf43c08f758b8c545')

 prepare() {