Package Details: enlightenment-git 0.24.0.beta1.24079.gd63f4a53e-1

Git Clone URL: https://aur.archlinux.org/enlightenment-git.git (read-only, click to copy)
Package Base: enlightenment-git
Description: Enlightenment window manager - Development version
Upstream URL: http://www.enlightenment.org
Licenses: BSD
Conflicts: enlightenment
Provides: enlightenment=0.24.0.beta1.24079.gd63f4a53e, notification-daemon
Submitter: Scimmia
Maintainer: raster
Last Packager: raster
Votes: 64
Popularity: 0.158306
First Submitted: 2014-01-08 21:25
Last Updated: 2020-05-14 09:28

Dependencies (22)

Required by (47)

Sources (1)

Latest Comments

« First ‹ Previous ... 5 6 7 8 9 10 11 12 13 14 15 ... Next › Last »

Scimmia commented on 2013-11-25 16:46

For those that just want to follow the alpha/beta releases and not Git HEAD, a PKGBUILD is provided with each tarball. Just extract the tarball, cd into the <new dir>/pkgbuild and run makepkg.

PelPix commented on 2013-11-05 23:54

WAYLAND SUPPORT is what's causing it to crash! I figured it out! Disabled Wayland in E, EFL, and Elementary. Now it boots up without any SEGV's!

Scimmia commented on 2013-09-17 14:31

A bit of shuffling around of conditional and optional deps. Changes upstream required this.

Scimmia commented on 2013-09-15 16:20

I'm hesitant to recommend any specific AUR helper. I use yaourt and it does keep a local copy of VCS repos in /var/abs/local/yaourt, but yaourt has it's own issues. IMO, there is no 'perfect' AUR helper.

Nazfellun commented on 2013-09-01 14:51

Scimmia: Haha, wow, I actually do have the environment variable 'V' set. Builds fine without it :). Thanks for your assistance!


Also, unrelated question: do you know of an AUR helper that maintains a persistent local cache of source repositories for VCS-backed AUR packages? Don't like wasting the time+bandwidth using the ones I know of, and building them manually doesn't have much benefit from my point of view.

Scimmia commented on 2013-08-18 17:21

I thought about it, but when I built from that branch, the display was unusable. There have been some bug fixes since then, so it could very well have been fixed by now.

AFAIK, none of the deps, build options, or anything else that matters needs changed from this package. Anyone that wants to try E19, all you have to do is add #branch=devs/discomfitor/e19 to the end of the source line, ie:
-source=("git://git.enlightenment.org/core/$_pkgname.git")
+source=("git://git.enlightenment.org/core/$_pkgname.git#branch=devs/discomfitor/e19")

PelPix commented on 2013-08-18 17:16

It might be a good idea to make a split package, enlightenment19-git, for

http://git.enlightenment.org/core/enlightenment.git/log/?h=devs/discomfitor/e19

Scimmia commented on 2013-08-16 03:28

Well Nazfellun, that file looks good, so Autotools isn't the problem.

Do you have an environmental variable set for "V"? Looking at how the edje command is constructed, that would explain some things, including why you have verbose build logs. Either that or you've done something with AM_DEFAULT_VERBOSITY, but that doesn't seem to cause the error.

Try adding "unset V" before the autogen command and see if anything changes.

Nazfellun commented on 2013-08-15 21:31

@Scimmia:
Here's the makefile: http://shados.net/files/Makefile.enlightenment17-git

Scimmia commented on 2013-08-10 04:38

Slight dep update. If you want to use the Wayland client module, you need pixman-git.