Package Details: enlighten-git 0-2

Git Clone URL: https://aur.archlinux.org/enlighten-git.git (read-only)
Package Base: enlighten-git
Description: A small tool to modify LCD backlight brightness
Upstream URL: https://github.com/HalosGhost/enlighten
Keywords: backlight brightness cli
Licenses: GPL3
Submitter: HalosGhost
Maintainer: HalosGhost
Last Packager: HalosGhost
Votes: 3
Popularity: 0.007681
First Submitted: 2017-04-02 05:49
Last Updated: 2019-04-26 01:18

Latest Comments

dcaixinha commented on 2019-09-10 09:46

Thanks for the timely and detailed response @HalosGhost. I'll test it out with another package manager and see if the issue still shows up (any particular one you recommend?). Also, Kudos on getting to the 1.0 release ;)

HalosGhost commented on 2019-09-02 13:26

@dcaixinha,

Because this package builds from git master, if there have been new commits, it will build a new package (the latest at the moment being r31 because I haven't gotten around to sewing up the last few features; hopefully soon :P).

However, if building the package does not update the pkgver variable, then that is a bug in your AUR helper (presumably, that is yay in this circumstance). If you look at the PKGBUILD itself, you can see the pkgver() function which is used to update the pkgver variable on each build.

It sounds like it might be worth looking into the issue tracker for yay and seeing if anyone else is experiencing this problem.

Additionally, I am rapidly coming up on releasing 1.0 of enlighten, so there will Soon™ be a non-git package that you could use instead.

All the best,

dcaixinha commented on 2019-09-02 09:43

I think something's wrong with this package. It's always trying to install version 0-2, but then installs version enlighten-git-v0.9.r31.g6629893-1, resulting in the system thinking it always needs to update this package (e.g. when using yay). Can somebody confirm this please?

HalosGhost commented on 2018-08-22 13:52

mustaqim,

you are right! It is a make-dep. I will fix that tonight. Thank you for the comment :)

All the best,

mustaqim commented on 2018-08-22 12:16

Currently installation will fail with:

==> Starting build()...
/bin/sh: line 1: sphinx-build: command not found
rm: cannot remove 'doctree': No such file or directory
make: *** [Makefile:26: doc] Error 1
==> ERROR: A failure occurred in build().

python-sphinx is required as a dependency