Package Details: enki-editor-git 18.08.0.r3.g7ac303fc-1

Git Clone URL: https://aur.archlinux.org/enki-editor-git.git (read-only)
Package Base: enki-editor-git
Description: Text editor for programmers. Live preview in Markdown, reStructuredText and HTML
Upstream URL: http://enki-editor.org/
Licenses: GPL
Conflicts: enki-editor
Provides: enki-editor
Submitter: skydrome
Maintainer: willemw
Last Packager: willemw
Votes: 11
Popularity: 0.000132
First Submitted: 2012-08-03 18:43
Last Updated: 2018-12-20 21:20

Dependencies (15)

Required by (0)

Sources (1)

Latest Comments

1 2 Next › Last »

willemw commented on 2018-12-20 21:05

@after: by using easy_install you're bypassing installed packages.

Qutepart-git has been updated to solve the issue. Enki-editor-git (this package) may also get an update.

after commented on 2018-12-20 20:38

sudo easy_install qutepart fixed it for me, if anyone else has this problem.

after commented on 2018-12-20 19:56

I'm getting this message even though I have qutepart-git installed.

Traceback (most recent call last):
  File "/usr/bin/enki", line 6, in <module>
    from pkg_resources import load_entry_point
  File "/usr/lib/python3.7/site-packages/pkg_resources/__init__.py", line 3126, in <module>
    @_call_aside
  File "/usr/lib/python3.7/site-packages/pkg_resources/__init__.py", line 3110, in _call_aside
    f(*args, **kwargs)
  File "/usr/lib/python3.7/site-packages/pkg_resources/__init__.py", line 3139, in _initialize_master_working_set
    working_set = WorkingSet._build_master()
  File "/usr/lib/python3.7/site-packages/pkg_resources/__init__.py", line 581, in _build_master
    ws.require(__requires__)
  File "/usr/lib/python3.7/site-packages/pkg_resources/__init__.py", line 898, in require
    needed = self.resolve(parse_requirements(requirements))
  File "/usr/lib/python3.7/site-packages/pkg_resources/__init__.py", line 784, in resolve
    raise DistributionNotFound(req, requirers)
pkg_resources.DistributionNotFound: The 'qutepart' distribution was not found and is required by enki

gergelyk commented on 2018-01-04 19:44

Following directory seems to be missing: /usr/lib/python3.6/site-packages/enki/plugins/preview/rst_templates

willemw commented on 2014-07-16 08:22

@mindsystem: Thanks. Updated optdepends.

mindsystem commented on 2014-07-15 19:42

According to the source install instructions (http://enki-editor.org/install-sources.html), the "tre" package (found in community repo) is an optional dependancy.
Adding the line: "tre: Approximate regex matching" or something to the optdepends section would be just a little nicety.

Rax_Garfield commented on 2013-08-14 15:40

Enki now depends on Qutepart instead of QScintilla; adopted and updated the previously orphaned PKGBUILD.

skydrome commented on 2012-08-19 19:35

what has that got to do with anything here?

Anonymous comment on 2012-08-18 15:18

Errors, log:


update desktop mime database...
Warning in file "/usr/share/applications/xarchiver.desktop": usage of MIME type "multipart/x-zip" is discouraged ("multipart" is a media type that probably does not make sense in this context)
Warning in file "/usr/share/applications/enlightenment_filemanager.desktop": usage of MIME type "x-directory/normal" is discouraged ("x-directory" is an old media type that should be replaced with a modern equivalent)
Error in file "/usr/share/applications/kde4/kmplayer.desktop": "uri/mms" is an invalid MIME type ("uri" is an unregistered media type)
Error in file "/usr/share/applications/kde4/kmplayer.desktop": "uri/pnm" is an invalid MIME type ("uri" is an unregistered media type)
Error in file "/usr/share/applications/kde4/kmplayer.desktop": "uri/rtspt" is an invalid MIME type ("uri" is an unregistered media type)
Error in file "/usr/share/applications/kde4/kmplayer.desktop": "uri/rtspu" is an invalid MIME type ("uri" is an unregistered media type)
gtk-update-icon-cache: Cache file created successfully.

skydrome commented on 2012-08-03 20:03

@conan good eye, resolved