Package Details: enigma-dev-git 3881.cca83e0-1

Git Clone URL: https://aur.archlinux.org/enigma-dev-git.git (read-only, click to copy)
Package Base: enigma-dev-git
Description: ENIGMA, the Extensible Non-Interpreted Game Maker Augmentation.
Upstream URL: http://enigma-dev.org
Licenses: GPL
Conflicts: lateralgm
Provides: lateralgm
Submitter: gandalf3
Maintainer: CyberShadow
Last Packager: gandalf3
Votes: 2
Popularity: 0.000000
First Submitted: 2013-06-09 21:23
Last Updated: 2016-09-23 20:22

Latest Comments

« First ‹ Previous 1 2 3

gandalf3 commented on 2013-06-25 02:27

Try it running "lateralgm" instead of "enigma"

I had not tested that, since the main way to use the program (if you want the gui)
is by running lateralgm (which runs enigma automatically)

I don't have time to fix the enigma script at the moment but when I do I'll upload it.

UnsolvedCypher commented on 2013-06-24 22:49

I'm getting an error:
/usr/bin/enigma-dev: line 6: cd: /opt/enigma: No such file or directory
Error: Unable to access jarfile lgm16b4.jar

catlover2 commented on 2013-06-10 03:16

It works now. Thanks!

gandalf3 commented on 2013-06-10 02:53

Oops..
Should be fixed.
thanks

catlover2 commented on 2013-06-09 22:19

Executable bit needed:

catlover2@catlover2-desktop-Arch ~ % ls -l /usr/bin/{enigma-dev,lateralgm}
-rw-r--r-- 1 root root 172 Jun 9 15:02 /usr/bin/enigma-dev
-rwxr-xr-x 1 root root 160 Jun 9 15:03 /usr/bin/lateralgm*

And I can't access /opt/enigma-dev-git:

catlover2@catlover2-desktop-Arch ~ % ls -l /opt/enigma-dev-git
ls: cannot access /opt/enigma-dev-git/libcompileEGMf.so: Permission denied
ls: cannot access /opt/enigma-dev-git/install.py: Permission denied
ls: cannot access /opt/enigma-dev-git/packages: Permission denied
ls: cannot access /opt/enigma-dev-git/ENIGMAsystem: Permission denied
ls: cannot access /opt/enigma-dev-git/Windows: Permission denied
ls: cannot access /opt/enigma-dev-git/Readme.md: Permission denied
ls: cannot access /opt/enigma-dev-git/events_localless.res: Permission denied
ls: cannot access /opt/enigma-dev-git/Compilers: Permission denied
ls: cannot access /opt/enigma-dev-git/MacOS: Permission denied
ls: cannot access /opt/enigma-dev-git/pluginsource: Permission denied
ls: cannot access /opt/enigma-dev-git/plugins: Permission denied
ls: cannot access /opt/enigma-dev-git/Makefile: Permission denied
ls: cannot access /opt/enigma-dev-git/lgm16b4.jar: Permission denied
ls: cannot access /opt/enigma-dev-git/events.res: Permission denied
ls: cannot access /opt/enigma-dev-git/settings.ey: Permission denied
ls: cannot access /opt/enigma-dev-git/CompilerSource: Permission denied
total 0
d????????? ? ? ? ? ? Compilers/
d????????? ? ? ? ? ? CompilerSource/
d????????? ? ? ? ? ? ENIGMAsystem/
-????????? ? ? ? ? ? events_localless.res
-????????? ? ? ? ? ? events.res
-????????? ? ? ? ? ? install.py
-????????? ? ? ? ? ? lgm16b4.jar
-????????? ? ? ? ? ? libcompileEGMf.so
d????????? ? ? ? ? ? MacOS/
-????????? ? ? ? ? ? Makefile
d????????? ? ? ? ? ? packages/
d????????? ? ? ? ? ? plugins/
d????????? ? ? ? ? ? pluginsource/
-????????? ? ? ? ? ? Readme.md
-????????? ? ? ? ? ? settings.ey
d????????? ? ? ? ? ? Windows/

Therefore, nothing works:

catlover2@catlover2-desktop-Arch ~ % lateralgm
/usr/bin/lateralgm: line 2: cd: /opt/enigma-dev-git/: Permission denied
Error: Unable to access jarfile lgm16b4.jar
1 catlover2@catlover2-desktop-Arch ~ % enigma-dev
zsh: permission denied: enigma-dev

If I chmod +x /usr/bin/enigma-dev:

catlover2@catlover2-desktop-Arch ~ % enigma-dev
/usr/bin/enigma-dev: line 6: cd: /opt/enigma: No such file or directory
/usr/bin/lateralgm: line 2: cd: /opt/enigma-dev-git/: Permission denied
Error: Unable to access jarfile lgm16b4.jar

gandalf3 commented on 2013-06-09 21:26

In case anyone wants to know, I have uploaded a git version here:

https://aur.archlinux.org/packages/enigma-dev-git/

Anonymous comment on 2012-01-25 23:24

This package hasn't been updated; ENIGMA no longer uses SVN. I currently haven't had the time to update the package to the more recent Git version, but when I do, I'll upload it.

jsteel commented on 2012-01-25 14:11

You may wish to contact them to correct this:

> Arch: <Eh? No package either?>
http://enigma-dev.org/download.htm#Linux

Anonymous comment on 2011-04-23 21:58

ENIGMA is still in the development stage, so, if it doesn't work, wait for the next revision.

Add this to /etc/pacman.conf for a binary repository:
[enigma]
Server=http://dl.dropbox.com/u/6125077/enigma/repos/arch-linux/$arch