Package Details: energia 1.8.7E21-5

Git Clone URL: https://aur.archlinux.org/energia.git (read-only)
Package Base: energia
Description: Energia is a Arduino IDE clone for use with the MSP430 launchpad
Upstream URL: http://energia.nu/
Licenses: GPL
Provides: energia
Submitter: will.price94
Maintainer: mpento
Last Packager: mpento
Votes: 24
Popularity: 0.012052
First Submitted: 2013-01-07 23:18
Last Updated: 2019-02-09 21:46

Pinned Comments

mpento commented on 2018-01-21 14:49

GTKLookAndFeel Issue

In reference to the following error:

java.lang.Error: Cannot load com.sun.java.swing.plaf.gtk.GTKLookAndFeel
    at javax.swing.UIManager.initializeDefaultLAF(UIManager.java:1351)
    at javax.swing.UIManager.initialize(UIManager.java:1459)
    at javax.swing.UIManager.maybeInitialize(UIManager.java:1426)
    at javax.swing.UIManager.getLookAndFeel(UIManager.java:492)
    at processing.app.linux.GTKLookAndFeelFixer.installGtkPopupBugWorkaround(GTKLookAndFeelFixer.java:79)
    at processing.app.linux.Platform.setLookAndFeel(Platform.java:40)
    at processing.app.Base.guardedMain(Base.java:214)
    at processing.app.Base.main(Base.java:136)

After some research, this appears to be a problem in energia itself that was fixed in the arduino ide, which energia is derived from. For reasons unknown to me, that fix has not been propagated. The energia issue for this is still open and not assigned on github (https://github.com/energia/Energia/issues/980).

To work around this problem, as root, edit the 'energia' script located in /opt/energia/, change line 28 from this:

JAVA_OPTIONS=("-DAPP_DIR=$APPDIR" "-Dswing.defaultlaf=com.sun.java.swing.plaf.gtk.GTKLookAndFeel")

To this:

JAVA_OPTIONS=("-DAPP_DIR=$APPDIR")

Once a fix is available, I will incorporate it here.

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 Next › Last »

will.price94 commented on 2014-05-17 09:22

Cool, that's good to hear it worked for you too. I have a stellaris board too, so I'll see what that enumerates as. I would have thought they'd all be the same given that they're all using the EZ programmer

whakim commented on 2014-05-17 07:50

Finally! I can upload without running energia through sudo.
Yeah i do also have concern on the USB ID. It seems that there are other USB ID that need to be add. I search for the other USB ID also.

BTW, thanks for the help will.price94

whakim commented on 2014-05-17 07:27

Finally! I can upload without running energia through sudo.

Thanks for the help will.price94

will.price94 commented on 2014-05-16 11:30

Ah OK. I hadn't actually had a Launchpad with me when I updated this script, but now I've got one to test I've managed to sort the problems. It seems that the device wasn't enumerating with the correct permissions so I've added a udev rule to the package to fix this. If you still get the same error I'll need the output of 'lsusb | grep -i ti' to add additional rules if TI don't consistently have the same USB ID across their product range.

I'll update the package in a few minutes after a bit more testing

whakim commented on 2014-05-16 09:42

hi will.price94
yes. i've add user to the lock group but still having problems with the permission during the upload process.

------
Trying to open interface 1 on 009
rf2500: warning: can't detach kernel driver: Operation not permitted
rf2500: can't claim interface: Operation not permitted
rf2500: failed to open RF2500 device

will.price94 commented on 2014-05-16 09:28

Hi Whakim,

It looks like the folder has the right permissions, have you added yourself to the lock group?

whakim commented on 2014-05-16 07:50

Hi will.price94, sorry for the late reply.

Output for both are as follows:

$ ls -l /run | grep lock
drwxrwxr-x 3 root lock 60 May 15 21:52 lock

$ ls -l /run/lock
total 0
drwx------ 2 root root 40 May 15 21:52 lvm

and executing
$ sudo chgrp lock /run/lock/lockdev
yield:
chgrp: cannot access ‘/run/lock/lockdev’: No such file or directory

Thanks

will.price94 commented on 2014-05-08 09:11

And one final question, did you reboot after installing? tmpfiles are installed at boot time.

will.price94 commented on 2014-05-08 09:08

If /run/lock/lockdev is owned by group root, you can run

$ sudo chgrp lock /run/lock/lockdev

Let me know if this fixes it and I'll add the permission change to the tmpfile.

will.price94 commented on 2014-05-08 09:06

Hi whakim,

Thanks for the tip, I've fixed the PKGBUILD.

Could you post the output of...

$ ls -l /run | grep lock
$ ls -l /run/lock

Could you also make sure that the tmpfile has been installed to /etc/tmpfiles.d/legacy.conf