Package Details: emos 4.5.9-2

Git Clone URL: https://aur.archlinux.org/emos.git (read-only, click to copy)
Package Base: emos
Description: ECMWF Interpolation Library
Upstream URL: https://software.ecmwf.int/wiki/display/EMOS/Emoslib
Licenses: Apache
Groups: science
Submitter: graziano
Maintainer: graziano
Last Packager: graziano
Votes: 4
Popularity: 0.000002
First Submitted: 2008-03-11 15:18
Last Updated: 2020-03-19 18:47

Dependencies (4)

Required by (2)

Sources (1)

Latest Comments

dquesada commented on 2020-02-18 22:07

Just in case somebody lands here because of this error (took me a while to figure it out, need emos for CDO):

[ 98%] Built target emos_sp
make: *** [Makefile:163: all] Error 2
==> ERROR: A failure occurred in build().

Install eccodes 2.10 changing on its build file:

  • pkgver=2.10.0

  • md5sums=('c32ba54676b2fa5e1ebd782528185cdd')

And then emos should install without problems.

Cheers!

Maduvi commented on 2019-11-21 07:05

I had some troubles and these two lines before the "mkdir -p build" command allowed a successful compilation:

sed -i sandbox/CMakeLists.txt -e 's/LIBS emos/LIBS emos eccodes/g'

sed -i tests/CMakeLists.txt -e 's/LIBS emos/LIBS emos eccodes/g'

I am not an expert using CMake so maybe this is not the most elegant approach.

graziano commented on 2014-08-26 20:23

@qs9rx : Fixed

qs9rx commented on 2014-08-26 17:17

depends on "grib_api"

graziano commented on 2013-02-25 12:36

Switched default to R64 as @ ECMWF