Package Details: emacs-with-editor 2.8.3-1

Git Clone URL: https://aur.archlinux.org/emacs-with-editor.git (read-only, click to copy)
Package Base: emacs-with-editor
Description: Use the Emacsclient as the of child processes
Upstream URL: http://github.com/magit/with-editor
Licenses: GPL3
Conflicts: emacs-with-editor-git
Provides: emacs-with-editor
Submitter: esben
Maintainer: esben
Last Packager: esben
Votes: 1
Popularity: 0.000012
First Submitted: 2018-06-07 11:53
Last Updated: 2019-11-04 06:50

Latest Comments

esben commented on 2019-11-04 06:38

Ok, so basically we cannot have versioned dependencies (against emacs). Kind of surprising given the PKGBUILD syntax. Anyway, I will remove it here and in other emacs related packages I maintain.

yar commented on 2019-11-03 23:09

Please remove the versioned emacs dependency by replacing 'emacs>=24.4' with just 'emacs'. It breaks emacs-nox, and the bug was closed as "Won't Implement": https://bugs.archlinux.org/task/60763

esben commented on 2019-11-02 10:48

Thanks. I have added git to makedepends.

smp commented on 2019-11-02 09:23

The way this PKGBUILD downloads the latest version of emacs-with-editor (using git+https) requires adding git to makedepends. Individual versions of emacs-with-editor can also be downloaded without relying on git from links like <https://github.com/magit/with-editor/archive/v2.8.3.tar.gz>.