Package Details: emacs-async 1.9.3-1

Git Clone URL: https://aur.archlinux.org/emacs-async.git (read-only, click to copy)
Package Base: emacs-async
Description: A module for doing asynchronous processing in Emacs
Upstream URL: https://github.com/jwiegley/emacs-async
Licenses: GPL3
Conflicts: emacs-async
Provides: emacs-async
Submitter: eyl
Maintainer: eyl
Last Packager: eyl
Votes: 1
Popularity: 0.000005
First Submitted: 2018-01-30 23:02
Last Updated: 2018-06-06 23:56

Latest Comments

aleksander0m commented on 2021-05-22 12:57

I'm trying to install emacs-magit and this is a dependency, but it's failing to build like this:

==> Removing existing $pkgdir/ directory...
==> Starting build()...
rm -f async-bytecomp.elc async-pkg.elc async-test.elc async.elc dired-async.elc smtpmail-async.elc
emacs -Q -batch --eval "(let ((generated-autoload-file (expand-file-name \"async-autoloads.el\" \".\")) \
(backup-inhibited t)) (update-directory-autoloads \".\"))"
emacs -Q -batch -L . -f batch-byte-compile async-bytecomp.el async-pkg.el async-test.el async.el dired-async.el smtpmail-async.el
Wrong type argument: stringp, nil
make: *** [Makefile:64: autoloads] Error 255
make: *** Waiting for unfinished jobs....
==> ERROR: A failure occurred in build().
    Aborting...
error making: emacs-async

It looks like the same issue was found in Debian and for what I could gather, they just skip running make/make install? https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=973150

Any idea?