Package Details: elementary-planner-git 2.5.7.r2.geae7508b-1

Git Clone URL: https://aur.archlinux.org/elementary-planner-git.git (read-only, click to copy)
Package Base: elementary-planner-git
Description: Task manager with Todoist support
Upstream URL: https://useplanner.com
Licenses: GPL3
Conflicts: elementary-planner, planner
Provides: elementary-planner, planner
Submitter: yochananmarqos
Maintainer: yochananmarqos
Last Packager: yochananmarqos
Votes: 7
Popularity: 0.122336
First Submitted: 2020-01-10 15:50
Last Updated: 2020-10-29 16:05

Latest Comments

1 2 3 Next › Last »

Alterego commented on 2020-12-25 17:09

Getting this error now

Json-CRITICAL **: 18:06:22.756: json_object_get_object_member: assertion 'node != NULL' failed

yochananmarqos commented on 2020-10-29 16:06

@Leon0402: Yep, gobject-introspection is now required to build.

@SupremeDeity: No, it's never a runtime dependency.

SupremeDeity commented on 2020-10-29 15:22

As @Leon0402 said, on v"2.5.7.r1.g1c84365a-1", edit the build file and add "gobject-introspection" before libpeas in the dependencies and apply.

Leon0402 commented on 2020-10-29 10:02

Libpeas seems to need gobject-introspection, adding it, I can build sucessfully. I'm not sure why it's not installed automatically? Could be rather an issue with the package itself?

I used "/usr/bin/pkg-config --modversion libpeas-1.0" to find it out.

yochananmarqos commented on 2020-10-27 15:37

@Bollos00: I've added the new dependency, not sure why it's not being detected. It was just added in the latest commit, use the stable elementary-planner 2.5.7 package for now.

Bollos00 commented on 2020-10-27 05:47

I have been facing an issue on the build step, it says that libpeas-1.0 but I checked and it is installed. Here is the issue:

Run-time dependency libpeas-1.0 found: NO (tried pkgconfig and cmake)

planner/meson.build:41:0: ERROR: Dependency "libpeas-1.0" not found, tried pkgconfig and cmake

A full log can be found at /.../elementary-planner-git/src/build/meson-logs/meson-log.txt
==> ERROR: A failure occurred in build().
    Aborting...
error making: elementary-planner-git

Here is the output for pacman -Qi libpeas:

Name            : libpeas
Version         : 1.26.0-1
Description     : A GObject plugins library
Architecture    : x86_64
URL             : https://wiki.gnome.org/Projects/Libpeas
Licenses        : GPL2
Groups          : None
Provides        : libpeas-1.0.so=0-64  libpeas-gtk-1.0.so=0-64
Depends On      : gtk3  gobject-introspection-runtime
Optional Deps   : python-gobject: Python loader [installed]
Required By     : eog  gedit  gitg
Optional For    : None
Conflicts With  : None
Replaces        : None
Installed Size  : 1050,56 KiB
Packager        : Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
Build Date      : dom 08 mar 2020 02:59:04
Install Date    : sáb 06 jun 2020 06:40:38
Install Reason  : Installed as a dependency for another package
Install Script  : No
Validated By    : Signature

I already have this package installed, so I just cannot update it. Anyway I thought it was better to report.

maciex commented on 2020-10-09 20:02

@yochananmarqos thanks. It works.

yochananmarqos commented on 2020-10-09 17:40

@maciex: I can't reproduce that with the 2.5.3 tag, but it does fail to build with the newest commit for a different reason. Here's a PKGBUILD for the stable version for now.

maciex commented on 2020-10-09 14:25

After upgrade of gnome and evolution-data-server I cannot start Planner. planner: error while loading shared libraries: libedataserver-1.2.so.24: cannot open shared object file: No such file or directory

ReverieMan commented on 2020-10-08 07:17

@yochananmarqo: sorry, missed. Thanks