Package Details: electron3 3.1.13-1

Git Clone URL: https://aur.archlinux.org/electron3.git (read-only)
Package Base: electron3
Description: Build cross platform desktop apps with web technologies
Upstream URL: https://electronjs.org/
Licenses: custom, MIT
Submitter: pat-s
Maintainer: pat-s
Last Packager: pat-s
Votes: 0
Popularity: 0.000000
First Submitted: 2019-07-01 05:37
Last Updated: 2019-09-17 16:45

Dependencies (28)

Sources (30)

Latest Comments

tuxayo commented on 2019-09-16 14:18

Hi, does anyone else get this error when building?

[788/1182] LINK openssl-cli
FAILED: openssl-cli 
clang -Wl,-O1,--sort-common,--as-needed,-z,relro,-z,now -Wl,-z,noexecstack --sysroot=/ -L//opt/android-sdk/tools/lib -Wl,-rpath-link=//opt/android-sdk/tools/lib -L//usr/lib/libfakeroot -Wl,-rpath-link=//usr/lib/libfakeroot -L//usr/lib32 -Wl,-rpath-link=//usr/lib32 -m64 -Wl,-z,noexecstack -fuse-ld=lld -Wl,-O1 -Wl,--as-needed -Wl,--gc-sections -flto=thin -Wl,--icf=all -Wl,--lto-O0 -Wl,-mllvm,-function-sections -Wl,-mllvm,-data-sections -o openssl-cli -Wl,--start-group obj/vendor/node/deps/openssl/openssl/apps/openssl-cli.app_rand.o obj/vendor/node/deps/openssl/openssl/apps/openssl-cli.apps.o obj/vendor/node/deps/openssl/openssl/apps/openssl-cli.asn1pars.o obj/vendor/node/deps/openssl/openssl/apps/openssl-cli.ca.o obj/vendor/node/deps/openssl/openssl/apps/openssl-cli.ciphers.o obj/vendor/node/deps/openssl/openssl/apps/openssl-cli.cms.o obj/vendor/node/deps/openssl/openssl/apps/openssl-cli.crl.o obj/vendor/node/deps/openssl/openssl/apps/openssl-cli.crl2p7.o obj/vendor/node/deps/openssl/openssl/apps/openssl-cli.dgst.o obj/vendor/node/deps/openssl/openssl/apps/openssl-cli.dhparam.o obj/vendor/node/deps/openssl/openssl/apps/openssl-cli.dsa.o obj/vendor/node/deps/openssl/openssl/apps/openssl-cli.dsaparam.o obj/vendor/node/deps/openssl/openssl/apps/openssl-cli.ec.o obj/vendor/node/deps/openssl/openssl/apps/openssl-cli.ecparam.o obj/vendor/node/deps/openssl/openssl/apps/openssl-cli.enc.o obj/vendor/node/deps/openssl/openssl/apps/openssl-cli.engine.o obj/vendor/node/deps/openssl/openssl/apps/openssl-cli.errstr.o obj/vendor/node/deps/openssl/openssl/apps/openssl-cli.gendsa.o obj/vendor/node/deps/openssl/openssl/apps/openssl-cli.genpkey.o obj/vendor/node/deps/openssl/openssl/apps/openssl-cli.genrsa.o obj/vendor/node/deps/openssl/openssl/apps/openssl-cli.nseq.o obj/vendor/node/deps/openssl/openssl/apps/openssl-cli.ocsp.o obj/vendor/node/deps/openssl/openssl/apps/openssl-cli.openssl.o obj/vendor/node/deps/openssl/openssl/apps/openssl-cli.opt.o obj/vendor/node/deps/openssl/openssl/apps/openssl-cli.passwd.o obj/vendor/node/deps/openssl/openssl/apps/openssl-cli.pkcs12.o obj/vendor/node/deps/openssl/openssl/apps/openssl-cli.pkcs7.o obj/vendor/node/deps/openssl/openssl/apps/openssl-cli.pkcs8.o obj/vendor/node/deps/openssl/openssl/apps/openssl-cli.pkey.o obj/vendor/node/deps/openssl/openssl/apps/openssl-cli.pkeyparam.o obj/vendor/node/deps/openssl/openssl/apps/openssl-cli.pkeyutl.o obj/vendor/node/deps/openssl/openssl/apps/openssl-cli.prime.o obj/vendor/node/deps/openssl/openssl/apps/openssl-cli.rand.o obj/vendor/node/deps/openssl/openssl/apps/openssl-cli.rehash.o obj/vendor/node/deps/openssl/openssl/apps/openssl-cli.req.o obj/vendor/node/deps/openssl/openssl/apps/openssl-cli.rsa.o obj/vendor/node/deps/openssl/openssl/apps/openssl-cli.rsautl.o obj/vendor/node/deps/openssl/openssl/apps/openssl-cli.s_cb.o obj/vendor/node/deps/openssl/openssl/apps/openssl-cli.s_client.o obj/vendor/node/deps/openssl/openssl/apps/openssl-cli.s_server.o obj/vendor/node/deps/openssl/openssl/apps/openssl-cli.s_socket.o obj/vendor/node/deps/openssl/openssl/apps/openssl-cli.s_time.o obj/vendor/node/deps/openssl/openssl/apps/openssl-cli.sess_id.o obj/vendor/node/deps/openssl/openssl/apps/openssl-cli.smime.o obj/vendor/node/deps/openssl/openssl/apps/openssl-cli.speed.o obj/vendor/node/deps/openssl/openssl/apps/openssl-cli.spkac.o obj/vendor/node/deps/openssl/openssl/apps/openssl-cli.srp.o obj/vendor/node/deps/openssl/openssl/apps/openssl-cli.ts.o obj/vendor/node/deps/openssl/openssl/apps/openssl-cli.verify.o obj/vendor/node/deps/openssl/openssl/apps/openssl-cli.version.o obj/vendor/node/deps/openssl/openssl/apps/openssl-cli.x509.o obj/vendor/node/deps/openssl/libopenssl.a -Wl,--end-group  -ldl -pthread
ld.lld: error: //lib64/gcc/x86_64-pc-linux-gnu/9.1.0/../../../../lib64/Scrt1.o is incompatible with elf_x86_64
ld.lld: error: //lib64/gcc/x86_64-pc-linux-gnu/9.1.0/../../../../lib64/crti.o is incompatible with elf_x86_64
ld.lld: error: //lib64/gcc/x86_64-pc-linux-gnu/9.1.0/crtbeginS.o is incompatible with elf_x86_64
ld.lld: error: obj/vendor/node/deps/openssl/openssl/apps/openssl-cli.app_rand.o is incompatible with elf_x86_64
ld.lld: error: obj/vendor/node/deps/openssl/openssl/apps/openssl-cli.apps.o is incompatible with elf_x86_64
ld.lld: error: obj/vendor/node/deps/openssl/openssl/apps/openssl-cli.asn1pars.o is incompatible with elf_x86_64
ld.lld: error: obj/vendor/node/deps/openssl/openssl/apps/openssl-cli.ca.o is incompatible with elf_x86_64
ld.lld: error: obj/vendor/node/deps/openssl/openssl/apps/openssl-cli.ciphers.o is incompatible with elf_x86_64
ld.lld: error: obj/vendor/node/deps/openssl/openssl/apps/openssl-cli.cms.o is incompatible with elf_x86_64
ld.lld: error: obj/vendor/node/deps/openssl/openssl/apps/openssl-cli.crl.o is incompatible with elf_x86_64
ld.lld: error: obj/vendor/node/deps/openssl/openssl/apps/openssl-cli.crl2p7.o is incompatible with elf_x86_64
ld.lld: error: obj/vendor/node/deps/openssl/openssl/apps/openssl-cli.dgst.o is incompatible with elf_x86_64
ld.lld: error: obj/vendor/node/deps/openssl/openssl/apps/openssl-cli.dhparam.o is incompatible with elf_x86_64
ld.lld: error: obj/vendor/node/deps/openssl/openssl/apps/openssl-cli.dsa.o is incompatible with elf_x86_64
ld.lld: error: obj/vendor/node/deps/openssl/openssl/apps/openssl-cli.dsaparam.o is incompatible with elf_x86_64
ld.lld: error: obj/vendor/node/deps/openssl/openssl/apps/openssl-cli.ec.o is incompatible with elf_x86_64
ld.lld: error: obj/vendor/node/deps/openssl/openssl/apps/openssl-cli.ecparam.o is incompatible with elf_x86_64
ld.lld: error: obj/vendor/node/deps/openssl/openssl/apps/openssl-cli.enc.o is incompatible with elf_x86_64
ld.lld: error: obj/vendor/node/deps/openssl/openssl/apps/openssl-cli.engine.o is incompatible with elf_x86_64
ld.lld: error: obj/vendor/node/deps/openssl/openssl/apps/openssl-cli.errstr.o is incompatible with elf_x86_64
ld.lld: error: too many errors emitted, stopping now (use -error-limit=0 to see all errors)
clang-8: error: linker command failed with exit code 1 (use -v to see invocation)
[793/1182] CXX obj/vendor/node/src/tracing/node_lib.node_trace_buffer.o
ninja: build stopped: subcommand failed.
==> ERARO: Malsukceso okazis en build().
    Ĉesigante...
Error making: electron3