Package Details: elasticsearch5 5.6.16-1

Git Clone URL: https://aur.archlinux.org/elasticsearch5.git (read-only, click to copy)
Package Base: elasticsearch5
Description: Distributed RESTful search engine built on top of Lucene
Upstream URL: https://www.elastic.co/products/elasticsearch
Licenses: Apache
Conflicts: elasticsearch
Provides: elasticsearch=5.6.16
Submitter: biinari
Maintainer: biinari
Last Packager: biinari
Votes: 5
Popularity: 0.000015
First Submitted: 2018-01-05 04:15
Last Updated: 2019-06-05 23:29

Required by (12)

Sources (7)

Latest Comments

girzel commented on 2021-05-05 21:33

Elasticsearch is failing to start for me with the error:

java.nio.file.NoSuchFileException: /usr/share/elasticsearch/config

There is, in fact, no such file there! On a whim I tried softlinking /usr/share/elasticsearch/config -> /etc/elasticsearch, and it got a little farther in the startup, but still failed.

Logs indicate:

org.elasticsearch.bootstrap.StartupException: ElasticsearchException[java.io.IOException: failed to read [id:1, legacy:false, file:/var/lib/elasticsearch/nodes/0/_state/node-1.st]]; nested: IOException[failed to read [id:1, legacy:false, file:/var/lib/elasticsearch/nodes/0/_state/node-1.st]]; nested: IllegalArgumentException[[node_meta_data] unknown field [node_version], parser not found];

I don't have any special config, but will be happy to pastebin full log files or whatever, if it would be helpful.

Samuelfaure commented on 2020-04-09 10:54

Thank you so much for this, you are my savior !