Package Details: eiskaltdcpp-gtk 2.2.10-4

Git Clone URL: https://aur.archlinux.org/eiskaltdcpp.git (read-only)
Package Base: eiskaltdcpp
Description: EiskaltDC++: Gtk2-based DC and ADC client based on dcpp core
Upstream URL: http://code.google.com/p/eiskaltdc/
Licenses: GPL3
Conflicts: eiskaltdcpp-gtk
Provides: eiskaltdcpp-gtk
Submitter: dhampire
Maintainer: kaptoxic
Last Packager: kaptoxic
Votes: 12
Popularity: 0.002954
First Submitted: 2015-08-11 22:08
Last Updated: 2018-03-02 23:05

Latest Comments

1 2 Next › Last »

iamashwin99 commented on 2019-11-16 16:27

If you get /usr/include/pango-1.0/pango/pango-coverage.h:28:10: fatal error: hb.h: No such file or directory 28 | #include <hb.h> | ^~~~~~ compilation terminated.

a temporary solution is to change /usr/include/pango-1.0/pango/pango-coverage.h and /usr/include/pango-1.0/pango/pango-font.h Where it includes hb.h, it should include harfbuzz/hb.h instead.

uzerus commented on 2019-07-14 22:35

"boost" package is required to build this

oi_wtf commented on 2018-07-06 10:15

You should rebuild eiskalt instead of symlinking the library.

A symlink might introduce problems which might silently corrupting something. A rebuild fails if there are problems and therefore is always safer.

aksh1618 commented on 2018-07-05 13:02

I was getting error due to older version og libboost_system.so not being available:

eiskaltdcpp-qt: error while loading shared libraries: libboost_system.so.1.66.0: cannot open shared object file: No such file or directory

So I created a symlink to current version to get it working:

ln -s /usr/lib/libboost_system.so.1.67.0 /usr/lib/libboost_system.so.1.66.0

kaptoxic commented on 2018-03-02 23:25

I fixed the build not to use local boost libraries; should be fine now.

Skipperio commented on 2018-03-02 20:32

https://hastebin.com/muxunocayu.cpp

collect2: error: ld returned 1 exit status make[2]: [eiskaltdcpp-gtk/CMakeFiles/eiskaltdcpp-gtk.dir/build.make:931: eiskaltdcpp-gtk/eiskaltdcpp-gtk] Error 1 make[1]: [CMakeFiles/Makefile2:361: eiskaltdcpp-gtk/CMakeFiles/eiskaltdcpp-gtk.dir/all] Error 2 make: *** [Makefile:130: all] Error 2 ==> ERROR: A failure occurred in package_eiskaltdcpp-gtk(). Aborting... :: Unable to build eiskaltdcpp-core - makepkg exited with code: 2

kaptoxic commented on 2017-09-21 00:56

Added; thanks.

oi_wtf commented on 2017-09-21 00:29

You should add openssl-1.0 instead of openssl as dependency wherever appropriate as well.

kaptoxic commented on 2017-09-17 05:37

Great, indeed, it works now! Done, I've made the change. (Using local definitions rather than exports though.) Thanks AG_Caesar!

AG_Caesar commented on 2017-09-10 21:25

Ha! I solved it:
Change the build section from
build() {
cd ${srcdir}/${_name}-${_tarver}
rm -rf ${srcdir}/${_name}-${_tarver}/build
mkdir ${srcdir}/${_name}-${_tarver}/build
cd ${srcdir}/${_name}-${_tarver}/build
cmake ../ -DENABLE_STACKTRACE=ON -DCMAKE_INSTALL_PREFIX=/usr -DUSE_MINIUPNP=ON -DLOCAL_MINIUPNP=ON -DPERL_REGEX=ON -DLOCAL_BOOST=ON -DLUA_SCRIPT=ON -DWITH_LUASCRIPTS=ON -DWITH_DHT=ON -DUSE_QT=OFF
}

to:

build() {
cd ${srcdir}/${_name}-${_tarver}
rm -rf ${srcdir}/${_name}-${_tarver}/build
mkdir ${srcdir}/${_name}-${_tarver}/build
cd ${srcdir}/${_name}-${_tarver}/build
export PKG_CONFIG_PATH=/usr/lib/openssl-1.0/pkgconfig
export CFLAGS=" -I/usr/include/openssl-1.0"
export LDFLAGS="-I/usr/lib/openssl-1.0"
cmake ../ -DENABLE_STACKTRACE=ON -DCMAKE_INSTALL_PREFIX=/usr -DUSE_MINIUPNP=ON -DLOCAL_MINIUPNP=ON -DPERL_REGEX=ON -DLOCAL_BOOST=ON -DLUA_SCRIPT=ON -DWITH_LUASCRIPTS=ON -DWITH_DHT=ON -DUSE_QT=OFF
}

Now it builds fine again. Could you add this to the pkg please? :)