Package Details: efl-git 1.23.99.64945.g8ec6e28b7c-1

Git Clone URL: https://aur.archlinux.org/efl-git.git (read-only, click to copy)
Package Base: efl-git
Description: Enlightenment Foundation Libraries - Development version
Upstream URL: http://www.enlightenment.org
Licenses: GPL2, custom, BSD, MIT, LGPL2.1
Conflicts: efl, elementary, elementary-git, elementary_test, elementary_test-git, evas_generic_loaders, evas_generic_loaders-git
Provides: efl=1.23.99.64945.g8ec6e28b7c, elementary=1.23.99.64945.g8ec6e28b7c, elementary-git=1.23.99.64945.g8ec6e28b7c, evas_generic_loaders=1.23.99.64945.g8ec6e28b7c
Submitter: Scimmia
Maintainer: raster
Last Packager: raster
Votes: 87
Popularity: 0.054589
First Submitted: 2013-02-15 10:00
Last Updated: 2020-01-28 08:35

Dependencies (59)

Required by (57)

Sources (1)

Latest Comments

« First ‹ Previous ... 29 30 31 32 33 34

Scimmia commented on 2012-10-29 22:13

andre.vmatos, thank you. The PKGBUILD has been updated.

andre.vmatos commented on 2012-10-29 21:19

efl-svn now replaces and provides embryo-svn too.

Scimmia commented on 2012-10-13 06:35

Yeah, the error was from me trying to include that extra commented out option. I swear I tested that, but oh well. Took that out and everything compiles again. Also had a problem with the licenses which should now be fixed.

Also changed eet-svn and eina-svn to "replace", but left eet and eina in conflicts. I think this is the right way to do this.

Cravix commented on 2012-10-13 06:03

well, you should change "conflicts" "replaces", and remove "md5sums".
and strangely, when i build it i get a error "-libexecdir=/usr/lib: no such directory"(or sth like that?), after i add # for that it works again.

Scimmia commented on 2012-10-13 04:41

If you're building E17 from the SVN PKGBUILDs in Community and getting errors about Eo.h, this is the package you need.
Since this is an SVN package, I left it using the default build profile, which is "dev". If you want "release", just uncomment "--with-profile=release \"

This is the first PKGBUILD I've put out into the public, so let me know if I did anything stupid. It's based off of the packages in Community from Ronald van Haren.

Scimmia commented on 2012-10-13 04:36

If you're building E17 from the SVN packages in Community and getting errors about Eo.h, this is the package you need.