Package Details: edk2-avmf 20200801-4

Git Clone URL: https://aur.archlinux.org/edk2-avmf.git (read-only, click to copy)
Package Base: edk2-avmf
Description: QEMU ARM/AARCH64 Virtual Machine Firmware (Tianocore UEFI firmware).
Upstream URL: https://fedoraproject.org/wiki/Using_UEFI_with_QEMU
Keywords: aarch64 Aavmf arm avmf edk2 qemu uefi
Licenses: BSD
Submitter: levinit
Maintainer: levinit (robertfoster, simona)
Last Packager: robertfoster
Votes: 5
Popularity: 0.46
First Submitted: 2019-08-15 13:30
Last Updated: 2021-02-07 10:31

Latest Comments

randyzhu commented on 2021-03-06 22:47

Appears to fail the validity check?

~/Packages/edk2-avmf(master) » makepkg -sir        randyzhu@randys-arch-machine
==> Making package: edk2-avmf 20200801-4 (Sat 06 Mar 2021 02:46:32 PM)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
  -> Downloading edk2-aarch64-20200801stable-4.fc34.noarch.rpm...
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100 2709k  100 2709k    0     0  1250k      0  0:00:02  0:00:02 --:--:-- 1250k
  -> Downloading edk2-arm-20200801stable-4.fc34.noarch.rpm...
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100 2677k  100 2677k    0     0  1576k      0  0:00:01  0:00:01 --:--:-- 1575k
==> Validating source files with sha256sums...
    edk2-aarch64-20200801stable-4.fc34.noarch.rpm ... FAILED
    edk2-arm-20200801stable-4.fc34.noarch.rpm ... FAILED
==> ERROR: One or more files did not pass the validity check!

killajoe commented on 2020-12-17 20:54

edk2-aarch64-20200801stable-3.fc34.noarch.rpm edk2-arm-20200801stable-3.fc34.noarch.rpm

You need to change pkgrel from 2 to 3 on PKGBUILD https://aur.archlinux.org/cgit/aur.git/tree/PKGBUILD?h=edk2-avmf#n6

simona commented on 2020-12-05 09:13

==> Validazione di source file con sha256sums...
edk2-aarch64-20200801stable-2.fc34.noarch.rpm ... NON RIUSCITO
edk2-arm-20200801stable-2.fc34.noarch.rpm ... NON RIUSCITO

simona commented on 2020-08-02 10:10

Can't load if nord vpn is enabled....

crazyquark commented on 2020-06-03 16:20

Worked for me on an ODROID-C2 running Arch Linux and a mainline kernel(5.4).

robertfoster commented on 2020-05-09 09:26

Hi, can you update to version 20200201 for fedora 32? Thank you