Package Details: eclipse-pydev 7.6.0-1

Git Clone URL: https://aur.archlinux.org/eclipse-pydev.git (read-only, click to copy)
Package Base: eclipse-pydev
Description: Python IDE for Eclipse
Upstream URL: http://pydev.org/
Licenses: EPL
Conflicts: eclipse-aptana
Submitter: darose
Maintainer: ozwigh
Last Packager: ozwigh
Votes: 9
Popularity: 0.79
First Submitted: 2017-01-10 23:02
Last Updated: 2020-06-11 23:30

Latest Comments

mluque commented on 2020-06-11 14:30

PyDev version 7.6.0 was released on 2020-06-04. It is available at

https://sourceforge.net/projects/pydev/files/pydev/PyDev%207.6.0/PyDev%207.6.0.zip/download

bartus commented on 2020-05-12 07:42

@ozwigh: how could I missed this, thanks for clarifying :)

ozwigh commented on 2020-05-11 14:32

There is https://aur.archlinux.org/packages/eclipse-platform/ which provides a bare minimum of eclipse and correct "provides=eclipse". I think it's how it should be. At least it always was like that.

Just comment one line and uncomment another.

[code] depends=('java-environment>=8' 'eclipse>=4.6')

for "eclipse-common/etc/etc" uncomment the next line.
depends=('java-environment>=8' 'eclipse-common>=4.6')

[/code]

Honestly, I don't know how to solve it without pain for someone. Maybe it's a good idea to remove the eclipse requirement at all? I doubt it's possible to unify all those AUR packages.

bartus commented on 2020-05-11 14:01

Doesn't work with current eclipse PKGBUILD in AUR

There's no package providing eclipse per se, you need to use eclipse-common>=4.6 instead.

ozwigh commented on 2020-05-11 09:04

Yep, downloads from SF can be troublesome. I added another (relatively fast) mirror. Also, with all those eclipse AUR variations, I decided to stick with those with "provides=eclipse". Feel free to edit PKGBUILD if needed.

jussihi commented on 2020-05-10 21:27

The download of the sourceforge file source sometimes seems to timeout, it only downloads first 512 bytes. Is there a possibility to add a more reliable source for the zip?

nyarna commented on 2019-02-26 02:09

Is this package orphaned?

darose commented on 2017-01-20 15:49

I'm orphaning this package. (Planning to use eclipse-dltk-python going forward.)

darose commented on 2017-01-12 17:08

Upgraded to PyDev 5.4.0