Package Details: eclipse-javascript 4.16-6

Git Clone URL: https://aur.archlinux.org/eclipse.git (read-only, click to copy)
Package Base: eclipse
Description: Highly extensible IDE
Upstream URL: https://eclipse.org
Licenses: EPL
Submitter: arojas
Maintainer: appadeia
Last Packager: appadeia
Votes: 28
Popularity: 6.85
First Submitted: 2020-05-01 18:40
Last Updated: 2020-07-03 17:13

Pinned Comments

appadeia commented on 2020-05-11 21:58

I've reverted changes that allowed multiple versions of Eclipse to be installed alongside eachother to investigate a less buggy method of allowing that.

Latest Comments

1 2 3 4 5 6 Next › Last »

followait commented on 2020-08-12 14:10

failed to install, reproduce:

1 git clone https://aur.archlinux.org/eclipse.git

2 edit PKGBUILD, replace one line as below

# source_x86_64+=(http://ftp-stud.fht-esslingen.de/pub/Mirrors/eclipse/technology/epp/downloads/release/$_release/$_src)
  source_x86_64+=(file:///local_path/$_src)

3 makepkg, error message:

curl: (37) Couldn't open file /local_path/eclipse-java-2020-06-R-linux-gtk-x86_64.tar.gz
==> ERROR: Failure while downloading file:///local_path/eclipse-java-2020-06-R-linux-gtk-x86_64.tar.gz
    Aborting...

4 questions:

4.1 Why does it try to find "eclipse-java-2020-06-R-linux-gtk-x86_64.tar.gz" instead of "eclipse-cpp-2020-06-R-linux-gtk-x86_64.tar.gz"?

4.2 How to install eclipse-cpp?

kronaemmanuel commented on 2020-08-07 15:48

Can I install just eclipse-java without installing/downloading any other? I'm currently getting an error where it says 'eclipse-common': File exists. The error occurs during prepare(). I don't even need the rest of the stuff, I just need eclipse-java.

mwyraz commented on 2020-07-29 06:39

Hello,

I'm always running eclipse with some custom environment variables set (commonly it's GTK_OVERLAY_SCROLLING=0 to get working scrollbars and GIT_SSH=/usr/bin/ssh to get working git ssh with ssh-agent support).

To set this env, I usually edit the launcher script at /usr/sbin/eclipse.

What do you think about this change to the launcher script that allows generic user-specific environment settings:

#!/bin/bash

# read user specific environment variables
if [ -f ~/.config/eclipse.rc ]; then
  . ~/.config/eclipse.rc
fi

export ECLIPSE_HOME=/usr/lib/eclipse
exec $ECLIPSE_HOME/eclipse "$@"

calegria commented on 2020-07-17 11:18

@appadeia I would like to help. What was the previous method? Why not just encapsulate everything in its own directory?

kmacleod commented on 2020-07-08 14:22

FYI, I ran into some issues, and decided to do a complete reinstall. I cleaned out the yay cache, etc.

I then ran into an issue installing from scratch:

==> Finished making: eclipse 4.16-6 (Wed 08 Jul 2020 10:08:22 AM) ==> Cleaning up... loading packages... resolving dependencies... warning: cannot resolve "eclipse-common=4.16-6", a dependency of "eclipse-java" :: The following package cannot be upgraded due to unresolvable dependencies: eclipse-java

:: Do you want to skip the above package for this upgrade? [y/N] error: failed to prepare transaction (could not satisfy dependencies) :: unable to satisfy dependency 'eclipse-common=4.16-6' required by eclipse-java

A successful workaround is to manually install eclipse-common first, then install eclipse-java.

snack commented on 2020-07-08 06:37

C++ indexing in 4.16-6 is partially broken. For example, autocompletion for memeber/methods does not work (even if they are somehow recognized since syntax highlighting seems to work) and method overrides are not properly signaled in the left side of the editor (left of the line number). Fortunately the workspace is still readable with 4.15 so it's possible to downgrade. Is anybody else experiencing the same?

lesto commented on 2020-07-07 08:28

mkdir: cannot create directory ‘eclipse-common’: File exists

please use mkdir -p (there are 2 instances)

to reproduce this error, use build folder that are persistent and upgrade from older version

Musikolo commented on 2020-07-05 03:13

For those using the popular lombok library, you might be interested in using my new lombok-eclipse-java package for a seamless integration.

Thank you.

Musikolo commented on 2020-07-05 03:12

For those using the popular lombok library, you might be interested in using my new lombok-eclipse-jee package for a seamless integration.

Thank you.

coderkun commented on 2020-07-04 09:31

I can confirm that version 4.16-6 of this package works well. Thanks for your work, @appadeia.