Package Details: eclim 2.8.0-3

Git Clone URL: https://aur.archlinux.org/eclim.git (read-only, click to copy)
Package Base: eclim
Description: Brings Eclipse functionality to Vim
Upstream URL: http://eclim.org/
Licenses: GPL3
Conflicts: eclim-git
Submitter: None
Maintainer: petronny
Last Packager: petronny
Votes: 122
Popularity: 0.052315
First Submitted: 2006-10-27 18:37
Last Updated: 2019-01-28 07:27

Dependencies (13)

Required by (0)

Sources (1)

Latest Comments

« First ‹ Previous ... 3 4 5 6 7 8 9 10 11 12 13 ... Next › Last »

glittershark commented on 2013-10-03 20:43

It looks like the issue here is with android specifically - I was encountering the same problem, but I uninstalled eclipse-android and it worked fine.

helloworld1 commented on 2013-09-10 01:10

After installation, I couldn't find the eclim view in the eclipse. Also eclimd failed to start for this error:


!SESSION 2013-09-09 18:08:45.040 -----------------------------------------------
eclipse.buildId=4.3.0.I20130605-2000
java.version=1.7.0_40
java.vendor=Oracle Corporation
BootLoader constants: OS=linux, ARCH=x86_64, WS=gtk, NL=en_US
Framework arguments: -refresh -application org.eclim.application
Command-line arguments: -debug -clean -refresh -application org.eclim.application

!ENTRY org.eclipse.osgi 4 0 2013-09-09 18:08:59.611
!MESSAGE Application error
!STACK 1
java.lang.RuntimeException: Application "org.eclim.application" could not be found in the registry. The applications available are: org.eclipse.ant.core.antRunner, org.eclipse.ant.ui.antRunner, org.eclipse.e4.ui.workbench.swt.E4Application, org.eclipse.e4.ui.workbench.swt.GenTopic, org.eclipse.equinox.app.error, org.eclipse.equinox.p2.director, org.eclipse.equinox.p2.garbagecollector.application, org.eclipse.equinox.p2.publisher.InstallPublisher, org.eclipse.equinox.p2.publisher.EclipseGenerator, org.eclipse.equinox.p2.publisher.ProductPublisher, org.eclipse.equinox.p2.publisher.FeaturesAndBundlesPublisher, org.eclipse.equinox.p2.reconciler.application, org.eclipse.equinox.p2.repository.repo2runnable, org.eclipse.equinox.p2.repository.metadataverifier, org.eclipse.equinox.p2.artifact.repository.mirrorApplication, org.eclipse.equinox.p2.metadata.repository.mirrorApplication, org.eclipse.equinox.p2.updatesite.UpdateSitePublisher, org.eclipse.equinox.p2.publisher.UpdateSitePublisher, org.eclipse.equinox.p2.publisher.CategoryPublisher, org.eclipse.help.base.infocenterApplication, org.eclipse.help.base.helpApplication, org.eclipse.help.base.indexTool, org.eclipse.jdt.apt.core.aptBuild, org.eclipse.jdt.core.JavaCodeFormatter, org.eclipse.jdt.core.JavaIndexer, org.eclipse.mat.api.parse, org.eclipse.mat.ui.rcp.application, org.eclipse.pde.build.Build, org.eclipse.pde.junit.runtime.uitestapplication, org.eclipse.pde.junit.runtime.legacytestapplication, org.eclipse.pde.junit.runtime.coretestapplication, org.eclipse.pde.junit.runtime.coretestapplicationnonmain, org.eclipse.pde.junit.runtime.nonuithreadtestapplication, org.eclipse.ui.ide.workbench.
at org.eclipse.equinox.internal.app.EclipseAppContainer.startDefaultApp(EclipseAppContainer.java:248)
at org.eclipse.equinox.internal.app.MainApplicationLauncher.run(MainApplicationLauncher.java:29)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:354)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:181)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:606)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:636)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:591)
at org.eclipse.equinox.launcher.Main.run(Main.java:1450)
at org.eclipse.equinox.launcher.Main.main(Main.java:1426)

huorpalantir commented on 2013-08-19 13:12

The build fails with the following error:

/tmp/yaourt-tmp-$user/aur-eclim/src/eclim_2.3.1/build.xml:31: The following error occurred while executing this line:
/tmp/yaourt-tmp-$user/aur-eclim/src/eclim_2.3.1/build.xml:141: : /tmp/yaourt-tmp-$user/aur-eclim/src/eclim_2.3.1/null does not exist.

It works when eclim fetches eclipse by itself, but I needed ADT (Android Debugging Tools), or the 'android nature' would not be installed, so I pre-installed eclipse-android from the AUR.

oconnor663 commented on 2013-08-12 19:29

The bug is that the directory "$pkgdir/usr/share/eclipse" needs to exist during packaging, but we're creating it too early in the build during the prepare() step. Makepkg then deletes the directory we created, and you can see "Removing existing pkg/ directory..." in the output. Moving the mkdir commands into the package() step fixes this issue. E.g. https://gist.github.com/oconnor663/6214243

oconnor663 commented on 2013-08-12 18:59

I'm seeing memand's error too. But 'pacman -R eclipse' isn't fixing it for me.

Anonymous comment on 2013-07-23 02:31

I now got it to compile by uninstalling eclipse and letting it fech it by it self....

Anonymous comment on 2013-07-23 01:37

I'm getting this error when building with yaourt:

BUILD FAILED
/tmp/yaourt-tmp-memand/aur-eclim/src/eclim_2.2.6/build.xml:31: The following error occurred while executing this line:
/tmp/yaourt-tmp-memand/aur-eclim/src/eclim_2.2.6/build.xml:137: : /tmp/yaourt-tmp-memand/aur-eclim/pkg/eclim/usr/share/eclipse does not exist.

?_?

lestb commented on 2013-06-16 08:01

The command for deleting Windows stuff can also be:

rm -f $(find $pkgdir -regex ".*bat\|.*cmd\|.*exe")

Hador commented on 2013-06-05 08:40

The warning can be safely ignored; in fact the only reference to $srcdir is the ac_pwd variable in nailgun's config.status.

I doubt it's going to break the build anytime soon; I'll fix it in the next update.

ervandew commented on 2013-06-04 21:19

> ok, this one did build. i did get a warning though:
> WARNING: Package contains reference to $srcdir

Yeah, I think recent versions of pacman have restructured how PKGBUILD scripts are suppose to work, so that's a warning that this PKGBUILD may break with later versions of pacman. I'm sure the fix is simple enough, I just haven't dug into the PKGBUILD docs at all. Hopefully the maintainer can tackle that.

> but it did work. thanks!

my pleasure.