Package Details: eclim 2.8.0-3

Git Clone URL: https://aur.archlinux.org/eclim.git (read-only, click to copy)
Package Base: eclim
Description: Brings Eclipse functionality to Vim
Upstream URL: http://eclim.org/
Licenses: GPL3
Conflicts: eclim-git
Submitter: None
Maintainer: None
Last Packager: petronny
Votes: 122
Popularity: 0.002114
First Submitted: 2006-10-27 18:37
Last Updated: 2019-01-28 07:27

Dependencies (13)

Required by (0)

Sources (1)

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 ... Next › Last »

asdas commented on 2018-10-23 21:06

Hello, building the package now fails with

eclim/PKGBUILD: line 33: /etc/profile.d/apache-ant.sh: No such file or directory

I guess apache-ant.sh isn't part of the ant package anymore.

petronny commented on 2018-08-20 05:28

@acquabob please try to build it with java-environment=8.

acquabob commented on 2018-08-17 01:44

Hi, I've been trying to post this repeatedly but I wasn't aware of the formatting.

Basically, when building/installing the package, I run into an error involving unmappable characters for encoding ASCII in the ViewUtils.java file. Here's the info dump (i'm only posting one part of it because I can't figure out how to indent/format the rest of the code and it's a nightmare to read. If anybody can tell me how to do formatting in these posts that'd be greatly appreciated) for one error:

/home/blodgett/eclim/src/eclim_2.8.0/org.eclim.jdt/java/org/eclim/plugin/jdt/command/debug/ui/ViewUtils.java:35: error: unmappable character for encoding ASCII

[javac] public static final String LEAF_NODE_SYMBOL = "??? "; [javac] ^ [javac] 9 errors

BUILD FAILED /home/blodgett/eclim/src/eclim_2.8.0/build.xml:27: The following error occurred while executing this line: /home/blodgett/eclim/src/eclim_2.8.0/build.xml:163: : Compile failed; see the compiler error output for details.

Does anybody know of anyway to resolve this? I think I know what the error means but not how to fix it. Any assistance is appreciated.

Anonymous comment on 2018-07-23 22:13

Thanks, I see, I have java 9 installed.

petronny commented on 2018-07-23 02:12

@Light2Yellow You have to build it with java-environment=8.

Anonymous comment on 2018-07-21 14:58

With version 2.8.0-1 I get this:

BUILD FAILED /tmp/makepkg/eclim/src/eclim_2.8.0/build.xml:27: The following error occurred while executing this line: /tmp/makepkg/eclim/src/eclim_2.8.0/build.xml:163: java.lang.NoClassDefFoundError: Unable to load class groovy.xml.jaxb.JaxbGroovyMethods due to missing dependency javax/xml/bind/JAXBContext

yourealwaysbe commented on 2018-05-29 13:31

With eclipse-scala-ide installed the build would fail with

"Could not load definitions from resource scala/tools/ant/antlib.xml. It could not be found."

I managed to successfully install by running

export CLASSPATH=$CLASSPATH:/usr/share/scala/lib/scala-compiler.jar

before making the package.

mony commented on 2018-03-08 16:17

@petronny thank you. BTW Eclim 2.7.2 is out https://github.com/ervandew/eclim/releases/

petronny commented on 2018-03-07 13:58

@mony Solved

mony commented on 2018-03-07 06:00

When I try to build eclim I get this error:

==> Starting package()... Buildfile: /tmp/yaourt-tmp/aur-eclim/src/eclim_2.7.1/build.xml

docs:

gant:

[echo] ${eclipse}: /usr/lib/eclipse

[echo] # Skipping org.eclim.wst, missing org.eclipse.wst.web_ui.feature

[echo] # Skipping org.eclim.sdt, missing org.scala-ide.sdt.feature

[echo] # Skipping org.eclim.pydev, missing org.python.pydev.feature

[echo] # Skipping org.eclim.pdt, missing org.eclipse.php

[echo] # Skipping org.eclim.groovy, missing org.codehaus.groovy.jdt.patch

[echo] # Skipping org.eclim.dltkruby, missing org.eclipse.dltk.ruby

[echo] # Skipping org.eclim.dltk, missing org.eclipse.dltk.core

[echo] # Skipping org.eclim.cdt, missing org.eclipse.cdt

[echo] # Skipping org.eclim.adt, missing com.android.ide.eclipse.adt.feature

[echo] Plugins:

[echo] org.eclim.jdt

[echo] eclim.version: 2.7.1

[echo] eclim.release: 2.7.1

org.eclim.jdt.classpath:

------ org.eclim.jdt.classpath

------ init

[mkdir] Created dir: /tmp/yaourt-tmp/aur-eclim/src/eclim_2.7.1/build/doc/site

[exec] Running Sphinx v1.7.1

[exec]

[exec] Extension error:

[exec] Could not import extension plantuml (exception: cannot import name Directive)

BUILD FAILED

/tmp/yaourt-tmp/aur-eclim/src/eclim_2.7.1/build.xml:114: The following error occurred while executing this line:

/tmp/yaourt-tmp/aur-eclim/src/eclim_2.7.1/build.xml:163: : exec returned: 2

Any idea?