Package Details: easyconnect 7.6.7.3.76b7ebc57725ae1e999151cdc215f8e7cef8a31b-1

Git Clone URL: https://aur.archlinux.org/easyconnect.git (read-only, click to copy)
Package Base: easyconnect
Description: Support access to ssl vpn. With easyconect,you can secure and speed up connection to cooperate network at ease!
Upstream URL: http://www.sangfor.com.cn
Licenses: custom
Submitter: attenuation
Maintainer: arthur_0
Last Packager: arthur_0
Votes: 4
Popularity: 0.62
First Submitted: 2018-07-28 12:09
Last Updated: 2020-03-13 08:15

Pinned Comments

arthur_0 commented on 2020-02-17 02:47

关于"您的客户端版本与服务器不匹配,请更新"的问题:

easyconnect服务器端会要求与客户端版本一致,因此,如果遇到版本过低或不一致情况,需手动修改PKGBUILD到你要连接的服务器端版本。

Latest Comments

1 2 3 Next › Last »

firefoxmmx commented on 2020-04-07 06:50

我这里提示“当前连接的vpn设备版本过低,不支持客户端下载” 这样的信息。

Italian_sunlight commented on 2020-03-27 01:56

一个问题:在kde下会闪退,报错“段错误”

ygp987 commented on 2020-03-08 04:34

麻烦问下,登录就闪退的问题怎么搞啊

deadlyn commented on 2020-03-08 00:27

你好,感谢你提供的软件包! 在分别访问2个不同服务器情况,报错不同:
1.输入地址,和用户密码点击登录,弹框显示“登录失败”, journalctl显示日志信息如下:

3月 08 08:18:18 eden kwin_x11[1526]: file:///usr/share/kwin/aurorae/MenuButton.qml:22: TypeError: Cannot read property 'closeOnDoubleClickOnMenu' of null
3月 08 08:18:18 eden kwin_x11[1526]: file:///usr/share/kwin/aurorae/MenuButton.qml:22: TypeError: Cannot read property 'closeOnDoubleClickOnMenu' of null

ECAgent.log显示:

[2020-03-08 08:25:59][D][ 893][ 138][DoQueryService][web]qry: QUERY GETHARDID
[2020-03-08 08:25:59][E][ 893][  66][StartCSClient][StartCSClient] get login user false
[2020-03-08 08:25:59][E][ 893][ 165][ConnectDomainSock][cms] /usr/share/sangfor/EasyConnect/resources/conf/ECDomainFile domain socket connect failed, errno:2.
[2020-03-08 08:25:59][E][ 893][ 114][Register]cms client connect failed.
[2020-03-08 08:25:59][E][ 893][ 165][ConnectDomainSock][cms] /usr/share/sangfor/EasyConnect/resources/conf/ECDomainFile domain socket connect failed, errno:2.
[2020-03-08 08:25:59][E][ 893][ 114][Register]cms client connect failed.

2.输入地址后确认,显示“您的客户端版本与服务器不匹配,请更新”,点击“好”打开浏览器,地址为:https://ip:port/com/EasyConnectPlugin.dmg
journalctl显示:与1一致。

ECAgent.log显示:

[2020-03-08 08:23:28][D][ 893][1638][FetchFromVPN][Agent][Enter]
[2020-03-08 08:23:29][D][ 893][1660][FetchFromVPN][Agent] status(404), error()
[2020-03-08 08:23:29][D][ 893][1661][FetchFromVPN][Agent] respnse(212:<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
<html><head>
<title>404 Not Found</title>
</head><body>
<h1>Not Found</h1>
<p>The requested URL /por/ec_pkg.csp was not found on this server.</p>
</body></html>
)
[2020-03-08 08:23:29][E][ 893][1671][FetchFromVPN]http response is error,status(404)
[2020-03-08 08:23:29][E][ 893][1093][RequestVersionRes]request version for vpn serror 

zhuhy051 commented on 2020-02-22 02:05

PKGBUILD版本回退后重新遇到 Harfbuzz version too old (1.3.1) 以及按照评论中方法解决后登录即闪退的问题,无法使用EasyConnect。

arthur_0 commented on 2020-02-17 02:47

关于"您的客户端版本与服务器不匹配,请更新"的问题:

easyconnect服务器端会要求与客户端版本一致,因此,如果遇到版本过低或不一致情况,需手动修改PKGBUILD到你要连接的服务器端版本。

gj313 commented on 2020-02-12 13:00

"当前连接的vpn设备版本过低,不支持客户端下载" 最新版没法使用

xyz1001 commented on 2020-02-12 09:11

您的客户端版本与服务器不匹配 解决办法:

  1. 重装easyconnect,安装过程中选择编辑pkgbuild文件
source= 
("http://download.sangfor.com.cn/download/product/sslvpn/pkg/linux_767/EasyConnect_x64_7_6_7_3.deb"
        "http://ftp.acc.umu.se/pub/GNOME/sources/pango/1.42/pango-1.42.4.tar.xz")
md5sums=('ac2020ce44583d5ee4552c81563dce9c'
          'deb171a31a3ad76342d5195a1b5bbc7c')

替换为

source=("http://download.sangfor.com.cn/download/product/sslvpn/pkg/linux_01/EasyConnect_x64.deb"
        "http://ftp.acc.umu.se/pub/GNOME/sources/pango/1.42/pango-1.42.4.tar.xz")
md5sums=('6ed6273f7754454f19835a456ee263e3'
          'deb171a31a3ad76342d5195a1b5bbc7c')
  1. 继续安装

Italian_sunlight commented on 2020-02-10 06:21

您的客户端版本与服务器不匹配,请下载更新 点进去以后,提供的软件包是deb或者rpm

nmamtf commented on 2020-02-05 14:28

您的客户端版本与服务器不匹配,请下载更新。 连接失败,然后会自动打开下载页面。下载页面上的链接和上个版本中的下载链接一致