Package Details: dxvk-mingw-git 1.1.1.r0.g37f9a7ff-2

Git Clone URL: https://aur.archlinux.org/dxvk-git.git (read-only)
Package Base: dxvk-git
Description: A Vulkan-based compatibility layer for Direct3D 10/11 which allows running 3D applications on Linux using Wine. Windows DLL version)
Upstream URL: https://github.com/doitsujin/dxvk
Keywords: dxvk
Licenses: zlib/libpng
Conflicts: dxvk-bin
Submitter: ssorgatem
Maintainer: ssorgatem
Last Packager: ssorgatem
Votes: 16
Popularity: 0.048914
First Submitted: 2018-01-24 19:41
Last Updated: 2019-05-04 19:32

Pinned Comments

ssorgatem commented on 2018-06-22 06:24

This package provides Windows binaries of the DXVK dlls. They work on wine and should work on Windows too. If you don't specifically want Windows binaries and you want to just use DXVK on wine, the winelib package is a better approach and much easier to build (dxvk-winelib-git).

To enable DXVK in a wineprefix, do the following (with the WINEPREFIX variable properly set):

setup_dxvk install

In order to uninstall DXVK from a wineprefix:

setup_dxvk uninstall

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 Next › Last »

ssorgatem commented on 2018-03-27 21:17

That's weird. It looks like a yaourt bug. Does it happen with a different paxkage manager?

zfkerr commented on 2018-03-27 18:47

Hi,@ssorgatem. What is it? Is it a bug or a feature?

Installing src/d3d11/libd3d11.dll.a to /home/user/Other/yaourt-tmp-user/aur-dxvk-git/src/dxvk-git/install.32/lib/libd3d11.dll.a
Installing /home/user/Other/yaourt-tmp-user/aur-dxvk-git/src/dxvk-git/build.32/wine_utils/setup_dxvk.sh to /home/user/Other/yaourt-tmp-user/aur-dxvk-git/src/dxvk-git/install.32/bin
rm: remove write-protected regular file 'dxvk-git/.git/objects/pack/pack-758597a9727cd86caccb335df52c2179f359eea6.pack'? y
rm: remove write-protected regular file 'dxvk-git/.git/objects/pack/pack-758597a9727cd86caccb335df52c2179f359eea6.idx'?

zfkerr commented on 2018-03-17 15:19

@ssorgatem, thank you very much!

ssorgatem commented on 2018-03-17 15:16

Change the "source" line to:

source=($pkgname::"git+https://github.com/doitsujin/dxvk.git#branch=direct-image-mapping")

zfkerr commented on 2018-03-17 15:13

Hi,@ssorgatem. How do I switch to direct-image-mapping DXVK branch editing your PKGBUILD?

https://github.com/doitsujin/dxvk/tree/direct-image-mapping

Yardanico commented on 2018-03-12 11:58

Also - I know it's not the best solution, but you can add blackarch repository (which has mingw-w64) or just download from it. There's also some mirrors available for blackarch

mozo commented on 2018-03-11 19:19

Thank you :)

ssorgatem commented on 2018-03-11 19:18

That is a problem with mingw-w64-gcc. Look at its AUR page for instructions on how to bootstrap its installation.

Alternatively, try the dxvk-bin package, for which you don't need a cross-compiler.

mozo commented on 2018-03-11 19:16

I get the following error:

(1/1) installing osl [############################] 100%

:: Running post-transaction hooks...

(1/1) Arming ConditionNeedsUpdate...

Edit mingw-w64-headers-bootstrap PKGBUILD with $EDITOR? [Y/n] n

==> Making package: mingw-w64-headers-bootstrap 5.0.3-1 (Sun Mar 11 21:12:40 EET 2018)

==> Checking runtime dependencies...

==> Checking buildtime dependencies...

==> Missing dependencies:

-> mingw-w64-headers

==> ERROR: Could not resolve all dependencies.

==> ERROR: An unknown error has occurred. Exiting...

The build failed.

The system doesn't show wihich dependency is missing :(

ssorgatem commented on 2018-03-10 15:50

It doesn't conflict with dxvk. It only conflicts with dxvk-bin because it provides the same files