Package Details: dwarffortress-spacefox 0.47.04-1

Git Clone URL: https://aur.archlinux.org/dwarffortress-spacefox.git (read-only, click to copy)
Package Base: dwarffortress-spacefox
Description: A single-player fantasy game. You control a dwarven outpost or an adventurer in a randomly generated persistent world. Packed with Spacefox's tileset and graphics pack. Does not replace other dwarffortress packages.
Upstream URL: http://www.bay12forums.com/smf/index.php?topic=129219.0
Licenses: custom:dwarffortress-sf
Submitter: winlu
Maintainer: wookietreiber
Last Packager: TheGoliath
Votes: 13
Popularity: 0.000000
First Submitted: 2014-08-16 07:49
Last Updated: 2020-05-15 10:37

Latest Comments

1 2 Next › Last »

shack commented on 2020-06-18 16:59

First time install, game segfaults with the following:

Sound devices available:
OpenAL Soft
Picking OpenAL Soft. If your desired device was missing, make sure you have the appropriate 32-bit libraries installed. If you wanted a different device, configure ~/.openalrc appropriately.
Perfect OpenAL context attributes GET
Loading bindings from data/init/interface.txt
zsh: segmentation fault (core dumped)  dwarffortress-sf

Fixed by copying libgraphics.so from the latest official build as per: https://www.bay12games.com/dwarves/mantisbt/view.php?id=10799

quaelgeist commented on 2019-02-23 10:41

Spacefox is currently on 44.11c ( https://github.com/DFgraphics/Spacefox/releases )

Unfuck is on 44.12 ( https://github.com/svenstaro/dwarf_fortress_unfuck/releases/tag/0.44.12 )

In response to:

stop flagging out of date, if it isn't

I am flagging this package out of date now, because it is.

pogojotz commented on 2017-12-16 12:14

Fails to build with the following error:

aur-dwarffortress-spacefox/src/dwarf_fortress_unfuck-0.42.06/g_src/ttf_manager.cpp:132:14 error: ‘modf’ was not declared in this scope fraction = modf(offset, &integral); ^~~~ Seems like an #include is missing

pankid commented on 2016-02-02 05:47

Does this randomly crash for anyone else as well? I get this message when it crashes. Segmentation fault (core dumped)

winlu commented on 2015-09-04 16:22

to build aur multilib packages you are supposed to have base-devel and multilib-devel (which includes gcc-multilib) installed, afaik they are not supposed to be listed in the requirements

winlu commented on 2015-09-04 16:22

to build aur packages multilib packages you are supposed to have base-devel and multilib-devel (which includes gcc-multilib) installed, afaik they are not supposed to be listed in the requirements

frukt commented on 2015-09-04 16:05

Note that compiling this (as of today, on my x86_64 system) *required* gcc-multilib to be installed.

frukt commented on 2015-09-04 15:56

Refuses to compile on a 64-bit system. Attempting to compile dwarf_fortress_unfuck produces several errors identical to

https://bpaste.net/show/89c758486a99

Demetri0 commented on 2015-08-14 10:01

http://i.imgur.com/8VzUpCz.png

Demetri0 commented on 2015-08-14 09:59