Package Details: dune-istl 2.6.0-1

Git Clone URL: https://aur.archlinux.org/dune-core.git (read-only, click to copy)
Package Base: dune-core
Description: Iterative solver template library
Upstream URL: http://www.dune-project.org
Licenses: custom
Groups: dune
Submitter: lubgr
Maintainer: PrinceMachiavell
Last Packager: PrinceMachiavell
Votes: 1
Popularity: 0.000000
First Submitted: 2016-07-21 10:41
Last Updated: 2019-12-13 21:22

Latest Comments

carlosal1015 commented on 2019-11-20 04:11

Hi @JoshH100, thank you very much. I installed without any problems dune-common.

I really want to learn mathematics with this program. I'll share the log of installation with us https://git.io/Je6JZ

PrinceMachiavell commented on 2019-11-14 17:44

@carlosal1015 Thanks for the notice. It seems that makepkg doesn't like that there is a function named 'package' in a split package PKGBUILD. I renamed the function to make_package and that seems to resolve the issue.

Let me know if there are any other issues... testing this kind of package is quite difficult.

carlosal1015 commented on 2019-11-11 04:59

Hi JoshH100, I hope could you help me. After the install all dependencies, i.e. 'cmake', 'gcc-fortran', 'openmpi', 'gmp', 'lapack', 'boost', 'superlu', 'suitesparse', 'parmetis', 'psurface'. I have the same result with dune-alugrid, dune-functions, dune-pddelab, dune-typtree and so on.

==> ERROR: Extra package() function for split package 'dune-core'

Thank you.

PrinceMachiavell commented on 2019-02-06 23:28

I've removed alberta since it seems to be abandoned and impossible to build currently. This means that neither the ug and alberta are usable as grid managers.

You'll probably need to uninstall all dune modules prior to building 2.6.0 otherwise CMAKE throws errors about needing modules. Chassing dependency circles is not fun.

Some of the other dune modules; alugrid, pdelab may not build ATM... If you find a git tag/commit # that builds I'm more than happy to pin them to those versions and create seperate -git suffix'ed versions to follow upstream.

franzf commented on 2018-05-24 11:04

I have the same problem as canelas.

canelas commented on 2018-05-07 17:52

Hi, I had a problem when installing dune-common. The problem was with the dependency "alberta", it said:

checking rpc/types.h usability... no checking rpc/types.h presence... no checking for rpc/types.h... no configure: error: Sorry, rpc/types.h is needed.

if I put CPPFLAGS=-I/usr/include/tirpc, then it says: checking rpc/types.h usability... yes checking rpc/types.h presence... yes checking for rpc/types.h... yes checking for rpc/xdr.h... yes checking for pow... yes checking for sqrt... yes checking for strdup... yes checking for strchr... yes checking for strstr... yes checking for rand... yes checking for srand... yes checking for xdr_int32_t... no configure: error: Sorry, these are needed..

What should I do? Thanks.

ni3k commented on 2017-03-19 13:23

https://dune-project.org/releases/2.5.0/

ni3k commented on 2017-03-19 13:20

UG This software is not maintained anymore:

http://www.iwr.uni-heidelberg.de/frame/iwrwikiequipment/software/ug

Please go to https://dune-project.org/modules/dune-uggrid/ for the maintained version, which is now fully integrated into DUNE as a DUNE module.