Package Details: dssp 3.0.0-3

Git Clone URL: https://aur.archlinux.org/dssp.git (read-only, click to copy)
Package Base: dssp
Description: Secondary structure assignment for proteins
Upstream URL: http://swift.cmbi.ru.nl/gv/dssp/HTML/distrib.html
Licenses: custom
Submitter: hseara
Maintainer: hseara
Last Packager: hseara
Votes: 3
Popularity: 0.000000
First Submitted: 2015-11-12 12:47
Last Updated: 2017-12-26 14:12

Dependencies (2)

Required by (0)

Sources (1)

Latest Comments

hseara commented on 2017-12-26 14:12

@acresearch Few comments:

1) Yaourt is a helper not officially supported by archlinux. Please try to install a package directly using makepkg prior reporting any problem.

2) NEVER use SUDO with yaourt. Please read the output of yaourt you posted for more information. You can literally destroy your computer by doing so.

3) I have added boost to the makedepends array

After correcting this issues if you still have a problem please let me know.

haawda commented on 2017-12-26 13:57

acresearch, do not run yaourt as root.

acresearch commented on 2017-12-20 11:06

I tried to install it today through 'sudo yaourt -S dssp' and I got this error, this is the full output:

[acresearch@acresearch ~]$ sudo yaourt -S dssp

==> Downloading dssp PKGBUILD from AUR...
x .SRCINFO
x PKGBUILD
acresearch commented on 2017-12-17 20:31             

hseara commented on 2017-12-19 10:29             

acresearch commented on 2017-12-19 12:10             

hseara commented on 2017-12-19 20:09             

dssp 3.0.0-1  (2017-12-19 20:06)
( Unsupported package: Potentially dangerous ! )
==> Edit PKGBUILD ? [Y/n] ("A" to abort)
==> ------------------------------------
==> y

Please add $VISUAL to your environment variables
for example:
export VISUAL="vim" (in ~/.bashrc)
(replace vim with your favorite editor)

==> Edit PKGBUILD with:  

/usr/lib/yaourt/util.sh: line 227: PKGBUILD: command not found
==> ERROR: Running makepkg as root is not allowed as it can cause permanent,
catastrophic damage to your system.
==> ERROR: An unknown error has occurred. Exiting...
Unable to read PKGBUILD
[acresearch@acresearch ~]$ 

I then tried to install it with the package manager:

Preparing...
Resolving dependencies...
Checking inter-conflicts...
Downloading...
Downloading gcc-libs-7.2.1-2-x86_64.pkg.tar.xz...
Downloading m4-1.4.18-1-x86_64.pkg.tar.xz...
Downloading autoconf-2.69-4-any.pkg.tar.xz...
Downloading automake-1.15.1-1-any.pkg.tar.xz...
Downloading binutils-2.29.1-1-x86_64.pkg.tar.xz...
Downloading bison-3.0.4-3-x86_64.pkg.tar.xz...
Downloading fakeroot-1.22-1-x86_64.pkg.tar.xz...
Downloading flex-2.6.4-1-x86_64.pkg.tar.xz...
Downloading gcc-7.2.1-2-x86_64.pkg.tar.xz...
Downloading make-4.2.1-2-x86_64.pkg.tar.xz...
Downloading patch-2.7.5-1-x86_64.pkg.tar.xz...
Downloading gc-7.6.0-1-x86_64.pkg.tar.xz...
Downloading guile-2.2.3-1-x86_64.pkg.tar.xz...
Downloading perl-error-0.17025-2-any.pkg.tar.xz...
Downloading git-2.15.1-1-x86_64.pkg.tar.xz...
Checking keyring...
Checking integrity...
Loading packages files...
Checking file conflicts...
Checking available disk space...
Removing gcc-libs-multilib (7.2.0-3)...
Installing gcc-libs (7.2.1-2)...
Installing m4 (1.4.18-1)...
Installing autoconf (2.69-4)...
Installing automake (1.15.1-1)...
Installing binutils (2.29.1-1)...
Installing bison (3.0.4-3)...
Installing fakeroot (1.22-1)...
Installing flex (2.6.4-1)...
Installing gcc (7.2.1-2)...
Installing gc (7.6.0-1)...
Installing guile (2.2.3-1)...
Installing make (4.2.1-2)...
Installing patch (2.7.5-1)...
Installing perl-error (0.17025-2)...
Installing git (2.15.1-1)...
Running post-transaction hooks...
Warn about old perl modules
Arming ConditionNeedsUpdate...
Updating the info directory file...

Building dssp...
Cloning into 'dssp'...
remote: Counting objects: 8, done.        
remote: Compressing objects: 100% (8/8), done.        
remote: Total 8 (delta 2), reused 2 (delta 0)        
Unpacking objects: 100% (8/8), done.
==> Making package: dssp 3.0.0-1 (ر ديسمبر 20 13:47:19 +03 2017)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
  -> Downloading dssp-3.0.0.tar.gz...
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100 47974  100 47974    0     0   5330      0  0:00:09  0:00:09 --:--:-- 13445
==> Validating source files with sha1sums...
    dssp-3.0.0.tar.gz ... Passed
==> Extracting sources...
  -> Extracting dssp-3.0.0.tar.gz with bsdtar
==> Starting prepare()...
==> Starting build()...
creating empty make.config file
compiling obj/mkdssp.o
In file included from src/iocif.h:6:0,
                 from src/mkdssp.cpp:14:
src/mas.h:31:10: fatal error: boost/version.hpp: No such file or directory
 #include <boost/version.hpp>
          ^~~~~~~~~~~~~~~~~~~
compilation terminated.
make: *** [makefile:64: obj/mkdssp.o] Error 1
==> ERROR: A failure occurred in build().
    Aborting...

I am sorry if I could not identify the source of the error, so I sent you here all the information I gatehred.

hseara commented on 2017-12-19 20:09

If someone can test the new package I will highly appreciate.

acresearch commented on 2017-12-19 12:10

Excellent, I will keep an eye for your update. DSSP is a cornerstone of Bioinformatics.

Much appreciated :-)

hseara commented on 2017-12-19 10:29

Boost in the 1.65 version has removed the TR1 module. For this reason, dssp is no longer compiling as it includes:

#include <boost/tr1/tuple.hpp>

Version 3.0.0 has the same problem. I'm checking the issue. Once, fixed I will upload the updated version.

acresearch commented on 2017-12-17 20:31

This package does not install properly in the Manjaro Linux Destribution (this package needs to makedepends on boost).