Package Details: ds9 8.2.1-1

Git Clone URL: https://aur.archlinux.org/ds9.git (read-only, click to copy)
Package Base: ds9
Description: SAOImage DS9: Astronomical Data Visualization Application
Upstream URL: http://hea-www.harvard.edu/RD/ds9/
Licenses: GPL2
Provides: ds9
Submitter: ydallilar
Maintainer: ydallilar
Last Packager: ydallilar
Votes: 4
Popularity: 0.078606
First Submitted: 2018-06-02 01:52
Last Updated: 2021-03-02 19:44

Latest Comments

ydallilar commented on 2021-03-01 12:40

@alastair87 Yes, you can't compile the newer version simply editing the PKGBUILD this case. Patience!

alastair87 commented on 2021-03-01 12:38

Modifying the PKGBUILD to use the sources for v8.2.1 leads to the following error:

==> Starting prepare()...
patching file tclxml/tclxml.c
Reversed (or previously applied) patch detected!  Skipping patch.
5 out of 5 hunks ignored -- saving rejects to file tclxml/tclxml.c.rej
patching file tclxml/tclxslt-libxslt.c
Reversed (or previously applied) patch detected!  Skipping patch.
1 out of 1 hunk ignored -- saving rejects to file tclxml/tclxslt-libxslt.c.rej
==> ERROR: A failure occurred in prepare().
    Aborting...

josesj commented on 2021-01-04 15:17

Thank you!

ydallilar commented on 2020-12-30 22:55

Wrote a patch, should compile now

josesj commented on 2020-12-30 15:35

Unable to build package. Compiling process of tclxml produces errors.

tclxml.c:1583:14: error: expected identifier or ‘(’ before ‘_Bool’
1583 |   int index, bool, doParse = 0, result;