Package Details: droidcam 6.7.5-1

Git Clone URL: https://aur.archlinux.org/droidcam.git (read-only)
Package Base: droidcam
Description: A tool for using your android device as a wireless/usb webcam
Upstream URL: https://www.dev47apps.com/droidcam/linuxx
Licenses: custom
Submitter: marquicus
Maintainer: AwesomeHaircut (jamesan)
Last Packager: AwesomeHaircut
Votes: 52
Popularity: 0.70
First Submitted: 2011-06-29 20:31
Last Updated: 2019-07-21 15:14

Pinned Comments

AwesomeHaircut commented on 2017-04-04 05:00

I don't use this anymore so if it's outdated or anything feel free to flag it out of date so I can update it! Before you compile make sure you're running the latest kernel

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 ... Next › Last »

ToxicAvenger commented on 2019-04-12 10:16

Its out of date, alright. How to compile it??

recolic commented on 2019-03-14 05:31

Here's updated PKGBUILD and install script. I have no permission to this repo so I'm posting it here. Hope it helps!

https://recolic.net/tmp/PKGBUILD https://recolic.net/tmp/droidcam.install

recolic commented on 2019-03-14 05:17

The module doesn't compile under linux 5.0. I have fixed the problem here, and you may use this patch directly.

Please update soon because ArchLinux kernel already goes 5.0.x

Blackflighter commented on 2019-01-12 05:23

Instead of the following line in the PKGBUILD: MODPATH="/usr/lib/modules/extramodules-$(uname -r | sed 's/.[0-9]+-[0-9]+//')"

This should be used instead, to allow for the module installation to work properly: MODPATH="/usr/lib/modules/extramodules-$(uname -r | sed 's/.*-//g')"

The droidcam.install file also needs modifying here: _extramodules="extramodules-$(uname -r | cut -f-2 -d'.')-$(uname -r|sed -e 's/.*-//g')"

To be replaced instead with: _extramodules="extramodules-$(uname -r | sed 's/.*-//g')"

This should get the proper name without including the version.

gilcu3 commented on 2018-09-17 15:33

as for kernel 4.18, the PKGBUILD needs a slight change to fix error: cat: /usr/lib/modules/extramodules-4.18-zen/version: No such file or directory that file is currently in /usr/lib/modules/extramodules-zen/

So version numbers got dropped from folder name

Kuchiriel commented on 2018-07-15 16:45

==> Iniciando build()... make -C /lib/modules/uname -r/build M=pwd make[1]: Entering directory '/usr/lib/modules/4.17.5-1-MANJARO/build' make[1]: No targets specified and no makefile found. Stop. make[1]: Leaving directory '/usr/lib/modules/4.17.5-1-MANJARO/build' make: [Makefile:4: all] Error 2 ==> ERRO: Uma falha ocorreu em build(). Abortando... ==> ERRO: Makepkg não conseguiu compilar droidcam.

AwesomeHaircut commented on 2018-05-04 15:53

Please make sure you reboot if you have updated your kernel.

mani.zaeim commented on 2018-05-04 05:45

make -C /lib/modules/uname -r/build M=pwd make[1]: warning: jobserver unavailable: using -j1. Add '+' to parent make rule. make[1]: /lib/modules/4.16.5-1-ARCH/build: No such file or directory. Stop. make: [Makefile:4: all] Error 2 ==> ERROR: A failure occurred in build(). Aborting... ==> ERROR: Makepkg was unable to build droidcam. ==> Restart building droidcam ? [y/N] ==> ---------------------------------

AwesomeHaircut commented on 2018-03-16 19:25

Ah great! I actually have to do a few things more than that but it should be straightforward thanks!

EbKeth commented on 2018-03-12 00:15

Issue has been resolved on this project's Git: https://github.com/aramg/droidcam/issues/7. Just need a package update for the new md5sums.