Package Details: downgrader-git 2.0.0.r158.f346695-3

Git Clone URL: https://aur.archlinux.org/downgrader-git.git (read-only, click to copy)
Package Base: downgrader-git
Description: Powerful packages downgrader for Archlinux. Works with libalpm, ARM and pacman logs
Upstream URL: https://github.com/DimaSmirnov/Archlinux-downgrader
Licenses: GPL
Conflicts: downgrader
Provides: downgrader
Submitter: asm0dey
Maintainer: asm0dey
Last Packager: asm0dey
Votes: 251
Popularity: 1.05
First Submitted: 2018-10-27 04:27
Last Updated: 2018-10-27 04:31

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 10 11 ... Next › Last »

keepitsimpleengr commented on 2014-01-20 17:31

Today's update(1.7.0-3) fails with:
gcc -g -c main.c -o main.o -std=c99 -Wno-implicit-function-declaration
main.c:8:19: fatal error: cJSON.h: No such file or directory
#include "cJSON.h"
^
compilation terminated.
Makefile:5: recipe for target 'main.o' failed
make: *** [main.o] Error 1

Linux kise-005 3.12.7-2-ARCH #1 SMP PREEMPT Sun Jan 12 13:09:09 CET 2014 x86_64 GNU/Linux

Spilver commented on 2014-01-20 16:43

Temporary I remove config support, my library is slightly unstable
Please update

thefrip commented on 2014-01-20 16:21

The default config file downgrader.conf is not copied through the PKGBUILD (only by the make install which is not triggered). This should be added.

bernd_b commented on 2013-12-29 21:48

I didn't use sudo. Sorry if I was unclear about this. I ran downgrader as user root.

If I start it as normal user, this happens:

=============================
downgrader -l vlc
Downgrade package: vlc

...

1: vlc-2.1.2-1 [installed]

...

8: vlc-2.0.8.a-1 [will be installed by default]
>> Please enter package number, [q] to quit , [d] to install default package: 8
[sudo] password for bernd_b:
Sorry, user bernd_b is not allowed to execute '/usr/bin/pacman -U http://repo-arm-download.archlinuxcn.org/extra/os/x86_64/vlc-2.0.8.a-1-x86_64.pkg.tar.xz' as root on amd64-archlinux
============================

So am I supposed to add /usr/bin/pacman to my /etc/sudoers config to use downgrader? I would have bet I did it once simply logged in as user root ...

Spilver commented on 2013-12-29 21:31

Please start downgrader without "sudo". And it will work like a sharm!
It will ask you a root password, when it will need them

bernd_b commented on 2013-12-29 11:58

No. It happens on different pc here in a terminal in X11 as well as in a virtual console - every time logged in as root.

Spilver commented on 2013-12-29 09:28

Hi. For me works ok.
Are you starting downgrader without "sudo" ?

bernd_b commented on 2013-12-28 22:47

Is this working for all but me?

=================
downgrader -l linux
Downgrade package: linux
Segmentation fault (core dumped)
=================

Spilver commented on 2013-08-30 11:03

1. Remove install script, I hope all users are updated =)
2. Migrating to new ARM service, in case old is dead
Version 1.6.7-4 released. Thanks for your help!

Spilver commented on 2013-08-29 17:46

1. Remove install script, I hope all users is updated =)
2. Migrating to new ARM service, in case old is dead
Version 1.6.7-4 released. Thanks for your help!